Vite: server.fs.deny bypassed with queries
CVE-2026-39364GHSA-v2wj-q39q-566r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 8.0.5, 7.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vite
- Affected
- >= 8.0.0, <= 8.0.4>= 7.1.0, <= 7.3.1
- Fixed in
- 7.3.2, 8.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v2wj-q39q-566r lists affected ranges: npm vite >=8.0.0 =7.1.0 <7.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v2wj-q39q-566r lists affected ranges: npm vite >=8.0.0 =7.1.0 <=7.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-39364: 2.26% estimated exploitation activity in the next 30 days; percentile 82.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The contents of files that are specified by server.fs.deny can be returned to the browser. Impact Only apps that match the following conditions are affected: - explicitly exposes the Vite dev server to the network (using --host or server.host config option) - the sensitive file exists in the allowed directories specified by server.fs.allow - the sensitive file is denied with a pattern that matches a file by server.fs.deny Details On the Vite dev server, files that should be blocked by server.fs.deny (e.g., .env, .crt) can be retrieved with HTTP 200 responses when query parameters such as ?raw, ?import&raw, or ?import&url&inline are appended. PoC 1. Start the dev server: pnpm exec vite root --host 127.0.0.1 --port 5175 --strictPort 2. Confirm that server.fs.deny is enforced (expect 403): curl -i http://127.0.0.1:5175/src/.env | head -n 20 <img width="3944" height="1092" alt="image" src="https://github.com/user-attachments/assets/ecb9f2e0-e08f-4ac7-b194-e0f988c4cd4f" / 3.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v2wj-q39q-566r
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v2wj-q39q-566r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-39364 Advisory: Vite: `server.fs.deny` bypassed with queries IDs: CVE-2026-39364, GHSA-v2wj-q39q-566r Record: https://patchnext.com/advisories/cve-2026-39364 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite 8.0.5, 7.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite: affected >= 8.0.0, <= 8.0.4; >= 7.1.0, <= 7.3.1; fixed in 7.3.2, 8.0.5 ## Suggested inspection (read-only) - `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v2wj-q39q-566r (OSV record GHSA-v2wj-q39q-566r lists affected ranges: npm vite >=8.0.0 =7.1.0 <7.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-v2wj-q39q-566r (GitHub-reviewed advisory GHSA-v2wj-q39q-566r lists affected ranges: npm vite >=8.0.0 =7.1.0 <=7.3.1) Commands are suggestions: review each one before running it.
Loading voting…