Drizzle ORM has SQL injection via improperly escaped SQL identifiers
CVE-2026-39356GHSA-gpj5-g38j-94v9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drizzle-orm 1.0.0-beta.20, 0.45.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm drizzle-orm
- Affected
- < 0.45.2>= 1.0.0-beta.2, < 1.0.0-beta.20
- Fixed in
- 1.0.0-beta.20, 0.45.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gpj5-g38j-94v9 lists affected ranges: npm drizzle-orm >=0 =1.0.0-beta.2 <1.0.0-beta.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gpj5-g38j-94v9 lists affected ranges: npm drizzle-orm >=0 =1.0.0-beta.2 <1.0.0-beta.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-39356: 0.39% estimated exploitation activity in the next 30 days; percentile 33.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Drizzle ORM improperly escaped quoted SQL identifiers in its dialect-specific escapeName() implementations. In affected versions, embedded identifier delimiters were not escaped before the identifier was wrapped in quotes or backticks. As a result, applications that pass attacker-controlled input to APIs that construct SQL identifiers or aliases, such as sql.identifier(), .as(), may allow an attacker to terminate the quoted identifier and inject SQL. Affected components The issue affects the identifier escaping logic used by the PostgreSQL, MySQL, SQLite, SingleStore, and Gel dialects. Impact This issue only affects applications that pass untrusted runtime input into identifier or alias construction. Common examples include dynamic sorting, dynamic report builders, and CTE or alias names derived from request parameters. Depending on the database dialect, query context, and database permissions, successful exploitation may enable blind or direct data disclosure, schema…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gpj5-g38j-94v9
- Revision 1 · created ·
Published from osv record GHSA-gpj5-g38j-94v9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-39356 Advisory: Drizzle ORM has SQL injection via improperly escaped SQL identifiers IDs: CVE-2026-39356, GHSA-gpj5-g38j-94v9 Record: https://patchnext.com/advisories/cve-2026-39356 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drizzle-orm 1.0.0-beta.20, 0.45.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm drizzle-orm: affected < 0.45.2; >= 1.0.0-beta.2, < 1.0.0-beta.20; fixed in 1.0.0-beta.20, 0.45.2 ## Suggested inspection (read-only) - `npm ls drizzle-orm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drizzle-orm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gpj5-g38j-94v9 (OSV record GHSA-gpj5-g38j-94v9 lists affected ranges: npm drizzle-orm >=0 =1.0.0-beta.2 <1.0.0-beta.20 (fixed)) - Verified: https://github.com/advisories/GHSA-gpj5-g38j-94v9 (GitHub-reviewed advisory GHSA-gpj5-g38j-94v9 lists affected ranges: npm drizzle-orm >=0 =1.0.0-beta.2 <1.0.0-beta.20) Commands are suggestions: review each one before running it.
Loading voting…