Skip to content

← Actionable
Critical, CVSS 9.0amended

PraisonAI Vulnerable to Arbitrary File Write / Path Traversal in Action Orchestrator

CVE-2026-39305GHSA-jfxc-v5g9-38xr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.113), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.5.112
    Fixed in
    4.5.113

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:H
EPSS
  • CVE-2026-39305: 0.31% estimated exploitation activity in the next 30 days; percentile 23.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Action Orchestrator feature contains a Path Traversal vulnerability that allows an attacker (or compromised agent) to write to arbitrary files outside of the configured workspace directory. By supplying relative path segments (../) in the target path, malicious actions can overwrite sensitive system files or drop executable payloads on the host. Details Location: src/praisonai/praisonai/cli/features/actionorchestrator.py (Lines 402, 409, 423) Vulnerable Code snippet: In the applystep method, paths are constructed by concatenating the workspace path with a user-supplied step.target string: target = workspace / step.target. The code fails to resolve and validate that the final absolute path remains within the bounds of the workspace directory. When processing FILECREATE or FILEEDIT actions, this flaw permits arbitrary file modification. PoC Construct a malicious ActionStep payload with path traversal characters: Impact This is an Arbitrary File Write vulnerability. Anyone running…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jfxc-v5g9-38xr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jfxc-v5g9-38xr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jfxc-v5g9-38xr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39305

Advisory: PraisonAI Vulnerable to Arbitrary File Write / Path Traversal in Action Orchestrator
IDs: CVE-2026-39305, GHSA-jfxc-v5g9-38xr
Record: https://patchnext.com/advisories/cve-2026-39305 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.113. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.5.112; fixed in 4.5.113

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jfxc-v5g9-38xr (GitHub-reviewed advisory GHSA-jfxc-v5g9-38xr lists affected ranges: PyPI praisonai >=0 <=4.5.112)
- Verified: https://osv.dev/vulnerability/GHSA-jfxc-v5g9-38xr (OSV record GHSA-jfxc-v5g9-38xr lists affected ranges: PyPI praisonai >=0 <4.5.113 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…