Skip to content

← Actionable
Medium, CVSS 5.1amended

OpenClaw: macOS beta onboarding exposed PKCE verifier via OAuth state

CVE-2026-3691GHSA-6g25-pc82-vfwp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.24
    Fixed in
    2026.2.25

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-3691: 0.46% estimated exploitation activity in the next 30 days; percentile 39.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The affected surface is the OpenClaw macOS app onboarding flow, and the macOS app is currently in beta. In that beta onboarding flow, Anthropic OAuth used the PKCE codeverifier value as OAuth state, exposing that secret in front-channel URL state. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.24 (latest published npm at triage time) - Affected surface: macOS app beta onboarding path (apps/macos) - Not affected: core CLI/gateway onboarding paths - Patched version : 2026.2.25 Impact Scope is limited to the macOS beta onboarding OAuth path. Exploitation required obtaining both OAuth authorization artifacts and exposed state values during that flow. Remediation OpenClaw removed Anthropic OAuth sign-in from macOS onboarding and now supports setup-token-only Anthropic subscription auth in this path. Fix Commit(s) - 8f3310000a8b0c11eced054c2cdb6fb27803511a Release Process Note patchedversions is pre-set to the release (2026.2.25). Advisory…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6g25-pc82-vfwp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6g25-pc82-vfwp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-3691

Advisory: OpenClaw: macOS beta onboarding exposed PKCE verifier via OAuth state
IDs: CVE-2026-3691, GHSA-6g25-pc82-vfwp
Record: https://patchnext.com/advisories/cve-2026-3691 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.24; fixed in 2026.2.25

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6g25-pc82-vfwp (OSV record GHSA-6g25-pc82-vfwp lists affected ranges: npm openclaw >=0 <2026.2.25 (fixed))
- Verified: https://github.com/advisories/GHSA-6g25-pc82-vfwp (GitHub-reviewed advisory GHSA-6g25-pc82-vfwp lists affected ranges: npm openclaw >=0 <=2026.2.24)

Commands are suggestions: review each one before running it.

Loading voting…