Skip to content

← Actionable
Medium, CVSS 6.1amended

fastify: request.protocol and request.host Spoofable via X-Forwarded-Proto/Host from Untrusted Connections

CVE-2026-3635GHSA-444r-cwp2-x5xf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 5.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fastify

    Affected
    <= 5.8.2
    Fixed in
    5.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-3635: 0.16% estimated exploitation activity in the next 30 days; percentile 5.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When trustProxy is configured with a restrictive trust function (e.g., a specific IP like trustProxy: '10.0.0.1', a subnet, a hop count, or a custom function), the request.protocol and request.host getters read X-Forwarded-Proto and X-Forwarded-Host headers from any connection — including connections from untrusted IPs. This allows an attacker connecting directly to Fastify (bypassing the proxy) to spoof both the protocol and host seen by the application. Affected Versions fastify <= 5.8.2 Impact Applications using request.protocol or request.host for security decisions (HTTPS enforcement, secure cookie flags, CSRF origin checks, URL construction, host-based routing) are affected when trustProxy is configured with a restrictive trust function. When trustProxy: true (trust everything), both host and protocol trust all forwarded headers — this is expected behavior. The vulnerability only manifests with restrictive trust configurations.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-444r-cwp2-x5xf

  2. Revision 1 · created ·

    Published from osv record GHSA-444r-cwp2-x5xf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-3635

Advisory: fastify: request.protocol and request.host Spoofable via X-Forwarded-Proto/Host from Untrusted Connections
IDs: CVE-2026-3635, GHSA-444r-cwp2-x5xf
Record: https://patchnext.com/advisories/cve-2026-3635 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastify 5.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fastify: affected <= 5.8.2; fixed in 5.8.3

## Suggested inspection (read-only)
- `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-444r-cwp2-x5xf (OSV record GHSA-444r-cwp2-x5xf lists affected ranges: npm fastify >=0 <5.8.3 (fixed))
- Verified: https://github.com/advisories/GHSA-444r-cwp2-x5xf (GitHub-reviewed advisory GHSA-444r-cwp2-x5xf lists affected ranges: npm fastify >=0 <=5.8.2)

Commands are suggestions: review each one before running it.

Loading voting…