OpenClaw: Scoped chat.send route inheritance could bypass admin command scope gates
CVE-2026-35674GHSA-hw9r-h9mr-4jff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.5.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.5.18
- Fixed in
- 2026.5.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hw9r-h9mr-4jff lists affected ranges: npm openclaw >=0 <2026.5.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hw9r-h9mr-4jff lists affected ranges: npm openclaw >=0 <2026.5.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-35674: 0.25% estimated exploitation activity in the next 30 days; percentile 16.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Some internal command handlers require operator.approvals or operator.admin scopes. In affected releases, a scoped Gateway chat.send request delivered through an inherited external route could be evaluated as an external-channel command while still carrying the lower Gateway client scopes. This issue affects scoped Gateway clients. It does not apply to shared-secret bearer HTTP compatibility endpoints, which are documented as full operator surfaces under OpenClaw's trust model. Affected configurations This affects deployments where a scoped Gateway caller with operator.write can use chat.send with delivery into a session that has an inherited external delivery route. Impact Commands that should have required operator.approvals or operator.admin could run with only operator.write in this routed context. Affected command families included approval resolution and selected administrative commands such as plugin, config, MCP, allowlist, and ACP mutations. Patched Versions The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hw9r-h9mr-4jff
- Revision 1 · created ·
Published from osv record GHSA-hw9r-h9mr-4jff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35674 Advisory: OpenClaw: Scoped chat.send route inheritance could bypass admin command scope gates IDs: CVE-2026-35674, GHSA-hw9r-h9mr-4jff Record: https://patchnext.com/advisories/cve-2026-35674 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.5.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.5.18; fixed in 2026.5.18 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hw9r-h9mr-4jff (OSV record GHSA-hw9r-h9mr-4jff lists affected ranges: npm openclaw >=0 <2026.5.18 (fixed)) - Verified: https://github.com/advisories/GHSA-hw9r-h9mr-4jff (GitHub-reviewed advisory GHSA-hw9r-h9mr-4jff lists affected ranges: npm openclaw >=0 <2026.5.18) Commands are suggestions: review each one before running it.
Loading voting…