OpenClaw: Forwarding header spoofing bypasses gateway.trustedProxies origin detection
CVE-2026-35656GHSA-844j-xrrq-wgh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.3.22
- Fixed in
- 2026.3.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-844j-xrrq-wgh4 lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-844j-xrrq-wgh4 lists affected ranges: npm openclaw >=0 <2026.3.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-35656: 0.31% estimated exploitation activity in the next 30 days; percentile 24.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When gateway.trustedProxies was configured, spoofed loopback hops in forwarding headers could be accepted as the client origin and weaken downstream auth and rate-limit decisions. Affected Packages / Versions - Package: openclaw (npm) - Affected: < 2026.3.22 - Fixed: = 2026.3.22 - Latest released tag checked: v2026.3.23-2 (630f1479c44f78484dfa21bb407cbe6f171dac87) - Latest published npm version checked: 2026.3.23-2 Fix Commit(s) - fc2d29ea926f47c428c556e92ec981441228d2a4 Release Status The fix shipped in v2026.3.22 and remains present in v2026.3.23 and v2026.3.23-2. Code-Level Confirmation - src/gateway/net.ts now ignores loopback forwarded hops before trusted-proxy client resolution. - That shipped origin fix is the one consumed by canvas auth and gateway auth-rate-limit paths that rely on resolved client identity. OpenClaw thanks @lintsinghua for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-844j-xrrq-wgh4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-844j-xrrq-wgh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35656 Advisory: OpenClaw: Forwarding header spoofing bypasses gateway.trustedProxies origin detection IDs: CVE-2026-35656, GHSA-844j-xrrq-wgh4 Record: https://patchnext.com/advisories/cve-2026-35656 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.3.22; fixed in 2026.3.22 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-844j-xrrq-wgh4 (OSV record GHSA-844j-xrrq-wgh4 lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed)) - Verified: https://github.com/advisories/GHSA-844j-xrrq-wgh4 (GitHub-reviewed advisory GHSA-844j-xrrq-wgh4 lists affected ranges: npm openclaw >=0 <2026.3.22) Commands are suggestions: review each one before running it.
Loading voting…