Skip to content

← Actionable
High, CVSS 8.1amended

OpenClaw: browser.request still allows POST /reset-profile through the operator.write surface

CVE-2026-35653GHSA-xp9r-prpg-373r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.3.24
    Fixed in
    2026.3.24

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-35653: 0.60% estimated exploitation activity in the next 30 days; percentile 48.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Fixed in OpenClaw 2026.3.24, the current shipping release. Title browser.request still allows POST /reset-profile through the operator.write surface in OpenClaw v2026.3.22 after GHSA-vmhq-cqm9-6p7q Severity Assessment High CWE: - CWE-863: Incorrect Authorization Proposed CVSS v3.1: - 8.1 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H) An authenticated caller who only has access to the scoped Gateway method browser.request on the operator.write surface can still reach a destructive persistent-profile management route. Likely related advisory family: - GHSA-vmhq-cqm9-6p7q This should be treated as a later-version residual or incomplete fix. The earlier fix blocked POST /profiles/create and profile deletion, but the latest released v2026.3.22 code still omits POST /reset-profile from the same mutation gate. Impact A caller with operator.write access to browser.request can still trigger persistent profile reset via POST /reset-profile. This crosses the intended privilege boundary for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xp9r-prpg-373r

  2. Revision 1 · created ·

    Published from osv record GHSA-xp9r-prpg-373r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35653

Advisory: OpenClaw: `browser.request` still allows `POST /reset-profile` through the `operator.write` surface
IDs: CVE-2026-35653, GHSA-xp9r-prpg-373r
Record: https://patchnext.com/advisories/cve-2026-35653 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.3.24; fixed in 2026.3.24

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xp9r-prpg-373r (OSV record GHSA-xp9r-prpg-373r lists affected ranges: npm openclaw >=0 <2026.3.24 (fixed))
- Verified: https://github.com/advisories/GHSA-xp9r-prpg-373r (GitHub-reviewed advisory GHSA-xp9r-prpg-373r lists affected ranges: npm openclaw >=0 <2026.3.24)

Commands are suggestions: review each one before running it.

Loading voting…