Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenClaw has ACP CLI approval prompt ANSI escape sequence injection

CVE-2026-35651GHSA-4hmj-39m8-jwc7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.28), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    >= 2026.2.13, <= 2026.3.24
    Fixed in
    2026.3.28

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-35651: 0.26% estimated exploitation activity in the next 30 days; percentile 17.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ACP CLI approval prompt ANSI escape sequence injection Affected Packages / Versions - Package: openclaw - Affected versions: = 2026.2.13, <= 2026.3.24 - First patched version: 2026.3.25 - Latest published npm version at verification time: 2026.3.24 Details ACP tool titles could previously carry ANSI control sequences into approval prompts and permission logs, letting untrusted tool metadata spoof terminal output. Commit 464e2c10a5edceb380d815adb6ff56e1a4c50f60 sanitizes tool titles at the source and broadens ANSI stripping to full CSI sequences. Verified vulnerable on tag v2026.3.24 and fixed on main by commit 464e2c10a5edceb380d815adb6ff56e1a4c50f60. Fix Commit(s) - 464e2c10a5edceb380d815adb6ff56e1a4c50f60

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4hmj-39m8-jwc7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4hmj-39m8-jwc7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35651

Advisory: OpenClaw has ACP CLI approval prompt ANSI escape sequence injection
IDs: CVE-2026-35651, GHSA-4hmj-39m8-jwc7
Record: https://patchnext.com/advisories/cve-2026-35651 (revision 3, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.28. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected >= 2026.2.13, <= 2026.3.24; fixed in 2026.3.28

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4hmj-39m8-jwc7 (OSV record GHSA-4hmj-39m8-jwc7 lists affected ranges: npm openclaw >=2026.2.13 <2026.3.28 (fixed))
- Verified: https://github.com/advisories/GHSA-4hmj-39m8-jwc7 (GitHub-reviewed advisory GHSA-4hmj-39m8-jwc7 lists affected ranges: npm openclaw >=2026.2.13 <=2026.3.24)

Commands are suggestions: review each one before running it.

Loading voting…