OpenClaw has an Arbitrary Malicious Code Execution Vulnerability
CVE-2026-35641GHSA-m3mh-3mpg-37hw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2025.3.23
- Fixed in
- 2026.3.24
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m3mh-3mpg-37hw lists affected ranges: npm openclaw >=0 <2026.3.24 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m3mh-3mpg-37hw lists affected ranges: npm openclaw >=0 <=2025.3.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-35641: 0.14% estimated exploitation activity in the next 30 days; percentile 3.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Fixed in OpenClaw 2026.3.24, the current shipping release. Summary During the installation phase of OpenClaw local plugins/hooks, the Git executable can be hijacked by a project-level .npmrc file, leading to arbitrary code execution during installation. Details Please note that the source code locations mentioned below are based on version openclaw-2026.3.13-1, but the issue has been confirmed to still exist in the current latest version, 2026.3.23. When installing a local plugin directory, local plugin archive, local hook pack directory, or local hook pack archive, OpenClaw first copies the source directory to a temporary stageDir, then executes the following in that directory: See src/infra/install-package-dir.ts:176-199. Since this process does not strip the project root .npmrc, and npm reads the project-level .npmrc during local project installation, an attacker could use a .npmrc file in a malicious plugin or hook directory to override npm’s git executable path. By leveraging a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m3mh-3mpg-37hw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m3mh-3mpg-37hw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35641 Advisory: OpenClaw has an Arbitrary Malicious Code Execution Vulnerability IDs: CVE-2026-35641, GHSA-m3mh-3mpg-37hw Record: https://patchnext.com/advisories/cve-2026-35641 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.24. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2025.3.23; fixed in 2026.3.24 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m3mh-3mpg-37hw (OSV record GHSA-m3mh-3mpg-37hw lists affected ranges: npm openclaw >=0 <2026.3.24 (fixed)) - Verified: https://github.com/advisories/GHSA-m3mh-3mpg-37hw (GitHub-reviewed advisory GHSA-m3mh-3mpg-37hw lists affected ranges: npm openclaw >=0 <=2025.3.23) Commands are suggestions: review each one before running it.
Loading voting…