Skip to content

← Actionable
Critical, CVSS 9.4amended

OpenClaw Gateway: RCE and Privilege Escalation from operator.pairing to operator.admin via device.pair.approve

CVE-2026-35639GHSA-hf68-49fm-59cq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.3.22
    Fixed in
    2026.3.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-35639: 0.46% estimated exploitation activity in the next 30 days; percentile 39.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary device.pair.approve allowed an operator.pairing approver to approve a pending device request for broader operator scopes than the approver actually held. Affected Packages / Versions - Package: openclaw (npm) - Affected: < 2026.3.22 - Fixed: = 2026.3.22 - Latest released tag checked: v2026.3.23-2 (630f1479c44f78484dfa21bb407cbe6f171dac87) - Latest published npm version checked: 2026.3.23-2 Fix Commit(s) - fc2d29ea926f47c428c556e92ec981441228d2a4 Release Status The fix shipped in v2026.3.22 and remains present in v2026.3.23 and v2026.3.23-2. Code-Level Confirmation - src/gateway/server-methods/devices.ts now threads caller scopes into device.pair.approve. - src/infra/device-pairing.ts now rejects requested operator scopes that exceed the approver-held operator scope set. OpenClaw thanks @zpbrent for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-hf68-49fm-59cq

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-hf68-49fm-59cq

  4. Revision 1 · created ·

    Published from ghsa record GHSA-hf68-49fm-59cq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35639

Advisory: OpenClaw Gateway: RCE and Privilege Escalation from operator.pairing to operator.admin via device.pair.approve
IDs: CVE-2026-35639, GHSA-hf68-49fm-59cq
Record: https://patchnext.com/advisories/cve-2026-35639 (revision 4, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.3.22; fixed in 2026.3.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hf68-49fm-59cq (GitHub-reviewed advisory GHSA-hf68-49fm-59cq lists affected ranges: npm openclaw >=0 <2026.3.22)
- Verified: https://osv.dev/vulnerability/GHSA-hf68-49fm-59cq (OSV record GHSA-hf68-49fm-59cq lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…