OpenClaw's Trusted-proxy Control UI sessions retain privileged scopes without device identity on device-less allow paths
CVE-2026-35638GHSA-48vw-m3qc-wr99
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.3.22
- Fixed in
- 2026.3.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-48vw-m3qc-wr99 lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48vw-m3qc-wr99 lists affected ranges: npm openclaw >=0 <2026.3.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-35638: 0.29% estimated exploitation activity in the next 30 days; percentile 21.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Trusted-proxy Control UI sessions without device identity could retain self-declared privileged scopes on the device-less allow path. Affected Packages / Versions - Package: openclaw (npm) - Affected: < 2026.3.22 - Fixed: = 2026.3.22 - Latest released tag checked: v2026.3.23-2 (630f1479c44f78484dfa21bb407cbe6f171dac87) - Latest published npm version checked: 2026.3.23-2 Fix Commit(s) - ccf16cd8892402022439346ae1d23352e3707e9e Release Status The fix shipped in v2026.3.22 and remains present in v2026.3.23 and v2026.3.23-2. Code-Level Confirmation - src/gateway/server/ws-connection/message-handler.ts now strips unbound self-declared scopes on the trusted-proxy no-device path. - src/gateway/server/ws-connection/connect-policy.ts remains the allow path, but the shipped scope scrub prevents privilege retention without device identity. OpenClaw thanks @nexrin for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-48vw-m3qc-wr99
- Revision 1 · created ·
Published from osv record GHSA-48vw-m3qc-wr99
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35638 Advisory: OpenClaw's Trusted-proxy Control UI sessions retain privileged scopes without device identity on device-less allow paths IDs: CVE-2026-35638, GHSA-48vw-m3qc-wr99 Record: https://patchnext.com/advisories/cve-2026-35638 (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.3.22; fixed in 2026.3.22 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-48vw-m3qc-wr99 (OSV record GHSA-48vw-m3qc-wr99 lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed)) - Verified: https://github.com/advisories/GHSA-48vw-m3qc-wr99 (GitHub-reviewed advisory GHSA-48vw-m3qc-wr99 lists affected ranges: npm openclaw >=0 <2026.3.22) Commands are suggestions: review each one before running it.
Loading voting…