OpenClaw: Gateway Canvas local-direct requests bypass Canvas HTTP and WebSocket authentication
CVE-2026-35634GHSA-6mqc-jqh6-x8fc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.3.23
- Fixed in
- 2026.3.23
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6mqc-jqh6-x8fc lists affected ranges: npm openclaw >=0 <2026.3.23 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6mqc-jqh6-x8fc lists affected ranges: npm openclaw >=0 <2026.3.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-35634: 0.14% estimated exploitation activity in the next 30 days; percentile 3.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Before v2026.3.23, Canvas and A2UI loopback requests could bypass Canvas bearer-or-capability authentication because authorizeCanvasRequest(...) treated isLocalDirectRequest(...) as an unconditional allow path. Affected Packages / Versions - Package: openclaw (npm) - Affected: < 2026.3.23 - Fixed: = 2026.3.23 - Latest released tag checked: v2026.3.23-2 (630f1479c44f78484dfa21bb407cbe6f171dac87) - Latest published npm version checked: 2026.3.23-2 Root Cause The vulnerable logic lived in src/gateway/server/http-auth.ts. authorizeCanvasRequest(...) returned { ok: true } for local-direct requests before checking bearer authentication or an active node canvas capability, which meant unauthenticated loopback Canvas HTTP and WebSocket requests could succeed. Fix Commit(s) - d5dc6b6573ae489bc7e5651090f4767b93537c9e — fix(gateway): require auth for canvas routes Release Status The fix commit is contained in released tags v2026.3.23 and v2026.3.23-2. The latest shipped tag and npm…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6mqc-jqh6-x8fc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6mqc-jqh6-x8fc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35634 Advisory: OpenClaw: Gateway Canvas local-direct requests bypass Canvas HTTP and WebSocket authentication IDs: CVE-2026-35634, GHSA-6mqc-jqh6-x8fc Record: https://patchnext.com/advisories/cve-2026-35634 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.23. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.3.23; fixed in 2026.3.23 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6mqc-jqh6-x8fc (OSV record GHSA-6mqc-jqh6-x8fc lists affected ranges: npm openclaw >=0 <2026.3.23 (fixed)) - Verified: https://github.com/advisories/GHSA-6mqc-jqh6-x8fc (GitHub-reviewed advisory GHSA-6mqc-jqh6-x8fc lists affected ranges: npm openclaw >=0 <2026.3.23) Commands are suggestions: review each one before running it.
Loading voting…