OpenClaw's mutating internal ACP chat commands missed operator.admin scope enforcement
CVE-2026-35631GHSA-3w6x-gv34-mqpf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.3.22
- Fixed in
- 2026.3.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3w6x-gv34-mqpf lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3w6x-gv34-mqpf lists affected ranges: npm openclaw >=0 <2026.3.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-35631: 0.22% estimated exploitation activity in the next 30 days; percentile 13.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Mutating internal ACP chat commands missed the operator.admin gate that should separate read-only and mutating control-plane actions. Affected Packages / Versions - Package: openclaw (npm) - Affected: < 2026.3.22 - Fixed: = 2026.3.22 - Latest released tag checked: v2026.3.23-2 (630f1479c44f78484dfa21bb407cbe6f171dac87) - Latest published npm version checked: 2026.3.23-2 Fix Commit(s) - 229426a257e49694a59fa4e3895861d02a4d767f Release Status The fix shipped in v2026.3.22 and remains present in v2026.3.23 and v2026.3.23-2. Code-Level Confirmation - src/auto-reply/reply/commands-acp.ts now requires operator.admin for mutating internal ACP actions. - src/auto-reply/reply/commands-acp.test.ts ships regression coverage for non-admin denial and admin success cases. OpenClaw thanks @tdjackey for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3w6x-gv34-mqpf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3w6x-gv34-mqpf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35631 Advisory: OpenClaw's mutating internal ACP chat commands missed operator.admin scope enforcement IDs: CVE-2026-35631, GHSA-3w6x-gv34-mqpf Record: https://patchnext.com/advisories/cve-2026-35631 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.3.22; fixed in 2026.3.22 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3w6x-gv34-mqpf (OSV record GHSA-3w6x-gv34-mqpf lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed)) - Verified: https://github.com/advisories/GHSA-3w6x-gv34-mqpf (GitHub-reviewed advisory GHSA-3w6x-gv34-mqpf lists affected ranges: npm openclaw >=0 <2026.3.22) Commands are suggestions: review each one before running it.
Loading voting…