Skip to content

← Actionable
High, CVSS 7.5amended

OpenClaw: QQBot native approval buttons did not enforce configured approver identity

CVE-2026-35630GHSA-mgq6-vr84-7m2j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.5.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.5.18
    Fixed in
    2026.5.18

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-35630: 0.21% estimated exploitation activity in the next 30 days; percentile 10.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenClaw's QQBot channel can deliver native approval buttons for exec and plugin approvals. In affected releases, the button callback path resolved approvals without enforcing the configured QQBot approver identity. The text command approval path used the authorization check; the issue was specific to native QQBot approval buttons. Affected configurations This affects deployments where QQBot native approval buttons are enabled and an approval message is visible to a QQ user who is not configured as an approver. Impact A non-approver who could see the approval message could click an approval button and resolve the pending request. Depending on the pending approval, this could allow an exec or plugin action that should have required an authorized approver. Patched Versions The first stable patched version is 2026.5.18. Mitigations Upgrade to openclaw@2026.5.18 or later. Before upgrading, avoid delivering native approval buttons into QQ conversations that include users who…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mgq6-vr84-7m2j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mgq6-vr84-7m2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35630

Advisory: OpenClaw: QQBot native approval buttons did not enforce configured approver identity
IDs: CVE-2026-35630, GHSA-mgq6-vr84-7m2j
Record: https://patchnext.com/advisories/cve-2026-35630 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.5.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.5.18; fixed in 2026.5.18

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mgq6-vr84-7m2j (OSV record GHSA-mgq6-vr84-7m2j lists affected ranges: npm openclaw >=0 <2026.5.18 (fixed))
- Verified: https://github.com/advisories/GHSA-mgq6-vr84-7m2j (GitHub-reviewed advisory GHSA-mgq6-vr84-7m2j lists affected ranges: npm openclaw >=0 <2026.5.18)

Commands are suggestions: review each one before running it.

Loading voting…