Skip to content

← Actionable
Critical, CVSS 9.2amended

PraisonAI Has Path Traversal in FileTools

CVE-2026-35615GHSA-693f-pf34-72c5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 1.5.113), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 1.5.112
    Fixed in
    1.5.113

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-35615: 0.42% estimated exploitation activity in the next 30 days; percentile 35.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Executive Summary: The path validation has a critical logic bug: it checks for .. AFTER normpath() has already collapsed all .. sequences. This makes the check completely useless and allows trivial path traversal to any file on the system. The path validation function also does not resolve the symlink wich could potentially cause path traversal. Details: validatepath() calls os.path.normpath() first, which collapses .. sequences, then checks for '..' in normalized. Since .. is already collapsed, the check always passes. Vulnerable File: src/praisonai-agents/praisonaiagents/tools/filetools.py Lines: 42-49 Severity: CRITICAL CVSS v3.1: 9.2 (CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N CWE: CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') Proof of concept (PoC) Prerequisites: - Ability to specify a file path can call file operations Steps to reproduce: poc.py Why this works: Impact: - Complete bypass of path traversal protection -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-693f-pf34-72c5

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-693f-pf34-72c5

  4. Revision 1 · created ·

    Published from ghsa record GHSA-693f-pf34-72c5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35615

Advisory: PraisonAI Has Path Traversal in FileTools
IDs: CVE-2026-35615, GHSA-693f-pf34-72c5
Record: https://patchnext.com/advisories/cve-2026-35615 (revision 4, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 1.5.113. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 1.5.112; fixed in 1.5.113

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-693f-pf34-72c5 (GitHub-reviewed advisory GHSA-693f-pf34-72c5 lists affected ranges: PyPI praisonai >=0 <=1.5.112)
- Verified: https://osv.dev/vulnerability/GHSA-693f-pf34-72c5 (OSV record GHSA-693f-pf34-72c5 lists affected ranges: PyPI praisonai >=0 <1.5.113 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…