Claude Code: Insecure System-Wide Configuration Loading Enables Local Privilege Escalation on Windows
CVE-2026-35603GHSA-5cwg-9f6j-9jvx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/claude-code 2.1.75), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.1.75
- Fixed in
- 2.1.75
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5cwg-9f6j-9jvx lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.1.75 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5cwg-9f6j-9jvx lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.1.75
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.4 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-35603: 0.11% estimated exploitation activity in the next 30 days; percentile 1.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
On Windows, Claude Code loaded system-wide default configuration from C:\ProgramData\ClaudeCode\managed-settings.json without validating directory ownership or access permissions. Because the ProgramData directory is writable by non-administrative users by default and the ClaudeCode subdirectory was not pre-created or access-restricted, a low-privileged local user could create this directory and place a malicious configuration file that would be automatically loaded for any user launching Claude Code on the same machine. Exploiting this would have required a shared multi-user Windows system and a victim user to launch Claude Code after the malicious configuration was placed. Users on standard Claude Code auto-update have received this fix already. Users performing manual updates are advised to update to the latest version. Thank you to hackerone.com/edbr for reporting this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5cwg-9f6j-9jvx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5cwg-9f6j-9jvx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35603 Advisory: Claude Code: Insecure System-Wide Configuration Loading Enables Local Privilege Escalation on Windows IDs: CVE-2026-35603, GHSA-5cwg-9f6j-9jvx Record: https://patchnext.com/advisories/cve-2026-35603 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/claude-code 2.1.75. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @anthropic-ai/claude-code: affected < 2.1.75; fixed in 2.1.75 ## Suggested inspection (read-only) - `npm ls @anthropic-ai/claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @anthropic-ai/claude-code. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5cwg-9f6j-9jvx (OSV record GHSA-5cwg-9f6j-9jvx lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.1.75 (fixed)) - Verified: https://github.com/advisories/GHSA-5cwg-9f6j-9jvx (GitHub-reviewed advisory GHSA-5cwg-9f6j-9jvx lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.1.75) Commands are suggestions: review each one before running it.
Loading voting…