Skip to content

← Actionable
High, CVSS 7.3amended

Glances has SSRF in IP Plugin via public_api leading to credential leakage

CVE-2026-35587GHSA-g5pq-48mj-jvw8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI glances

    Affected
    < 4.5.4
    Fixed in
    4.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-35587: 0.40% estimated exploitation activity in the next 30 days; percentile 33.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation of the publicapi configuration parameter. The value of publicapi is used directly in outbound HTTP requests without any scheme restriction or hostname/IP validation. An attacker who can modify the Glances configuration can force the application to send requests to arbitrary internal or external endpoints. Additionally, when publicusername and publicpassword are set, Glances automatically includes these credentials in the Authorization: Basic header, resulting in credential leakage to attacker-controlled servers. This vulnerability can be exploited to: Access internal network services (e.g., 127.0.0.1, 192.168.x.x) Retrieve sensitive data from cloud metadata endpoints (e.g., 169.254.169.254) Exfiltrate credentials via outbound HTTP requests The issue arises because publicapi is passed directly to the HTTP client (urlopenauth) without validation, allowing unrestricted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g5pq-48mj-jvw8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g5pq-48mj-jvw8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35587

Advisory: Glances has SSRF in IP Plugin via public_api leading to credential leakage
IDs: CVE-2026-35587, GHSA-g5pq-48mj-jvw8
Record: https://patchnext.com/advisories/cve-2026-35587 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: glances 4.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI glances: affected < 4.5.4; fixed in 4.5.4

## Suggested inspection (read-only)
- `python -m pip show glances`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on glances.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g5pq-48mj-jvw8 (OSV record GHSA-g5pq-48mj-jvw8 lists affected ranges: PyPI glances >=0 <4.5.4 (fixed))
- Verified: https://github.com/advisories/GHSA-g5pq-48mj-jvw8 (GitHub-reviewed advisory GHSA-g5pq-48mj-jvw8 lists affected ranges: PyPI glances >=0 <4.5.4)

Commands are suggestions: review each one before running it.

Loading voting…