Emissary has Stored XSS via Navigation Template Link Injection
CVE-2026-35571GHSA-cpm7-cfpx-3hvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gov.nsa.emissary:emissary 8.39.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven gov.nsa.emissary:emissary
- Affected
- <= 8.38.0
- Fixed in
- 8.39.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cpm7-cfpx-3hvp lists affected ranges: Maven gov.nsa.emissary:emissary >=0 <=8.38.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-35571: 0.18% estimated exploitation activity in the next 30 days; percentile 7.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Mustache navigation templates interpolated configuration-controlled link values directly into href attributes without URL scheme validation. An administrator who could modify the navItems configuration could inject javascript: URIs, enabling stored cross-site scripting (XSS) against other authenticated users viewing the Emissary web interface. Details Vulnerable code — nav.mustache (line 10) The {{link}} value was rendered without any scheme validation. Mustache's default HTML escaping protects against injection of new HTML tags but does not prevent javascript: URIs in href attributes, since javascript: contains no characters that HTML-escaping would alter. Attack vector An administrator sets a navigation item's link to: Any authenticated user who clicks the navigation link executes the script in their browser context. Impact - Session hijacking via cookie theft - Actions performed on behalf of the victim user - Requires administrative access to modify navigation…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cpm7-cfpx-3hvp
- Revision 1 · created ·
Published from ghsa record GHSA-cpm7-cfpx-3hvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35571 Advisory: Emissary has Stored XSS via Navigation Template Link Injection IDs: CVE-2026-35571, GHSA-cpm7-cfpx-3hvp Record: https://patchnext.com/advisories/cve-2026-35571 (revision 2, source checked 4 Nov 2026, 22:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gov.nsa.emissary:emissary 8.39.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven gov.nsa.emissary:emissary: affected <= 8.38.0; fixed in 8.39.0 ## Suggested inspection (read-only) - Maven gov.nsa.emissary:emissary: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gov.nsa.emissary:emissary. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cpm7-cfpx-3hvp (GitHub-reviewed advisory GHSA-cpm7-cfpx-3hvp lists affected ranges: Maven gov.nsa.emissary:emissary >=0 <=8.38.0) Commands are suggestions: review each one before running it.
Loading voting…