Skip to content

← Actionable
High, CVSS 8.4amended

OpenClaude: Sandbox Bypass via Early-Exit Logic Flaw Allows Path Traversal

CVE-2026-35570GHSA-m6rx-7pvw-2f73

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@gitlawb/openclaude 0.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-35570: 0.23% estimated exploitation activity in the next 30 days; percentile 14.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A logic flaw exists in bashToolHasPermission() inside src/tools/BashTool/bashPermissions.ts. When the sandbox auto-allow feature is active and no explicit deny rule is configured, the function returns an allow result immediately — before the path constraint filter (checkPathConstraints) is ever evaluated. This allows commands containing path traversal sequences (e.g., ../../../../../etc/passwd) to bypass directory restrictions entirely. Affected Component - File: src/tools/BashTool/bashPermissions.ts - Function: bashToolHasPermission - Location: ~line 1445 (sandbox auto-allow block) Vulnerable Code Flow The sandbox block was designed to skip interactive permission prompts in sandboxed environments. However, it unintentionally also skips the path traversal filter, which is a separate and critical security control. Impact Any process or user operating in a sandboxed session with no explicit deny rules can: - Read arbitrary files outside the sandbox boundary (e.g., /etc/passwd,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m6rx-7pvw-2f73

  2. Revision 1 · created ·

    Published from osv record GHSA-m6rx-7pvw-2f73

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35570

Advisory: OpenClaude: Sandbox Bypass via Early-Exit Logic Flaw Allows Path Traversal
IDs: CVE-2026-35570, GHSA-m6rx-7pvw-2f73
Record: https://patchnext.com/advisories/cve-2026-35570 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @gitlawb/openclaude 0.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @gitlawb/openclaude: affected < 0.5.1; fixed in 0.5.1

## Suggested inspection (read-only)
- `npm ls @gitlawb/openclaude --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @gitlawb/openclaude.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m6rx-7pvw-2f73 (OSV record GHSA-m6rx-7pvw-2f73 lists affected ranges: npm @gitlawb/openclaude >=0 <0.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-m6rx-7pvw-2f73 (GitHub-reviewed advisory GHSA-m6rx-7pvw-2f73 lists affected ranges: npm @gitlawb/openclaude >=0 <0.5.1)

Commands are suggestions: review each one before running it.

Loading voting…