Apache Storm UI: Stored Cross-Site Scripting (XSS) via Unsanitized Topology Metadata
CVE-2026-35565GHSA-f2hp-qw27-8wfq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.storm:storm-webapp 2.8.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.storm:storm-webapp
- Affected
- < 2.8.6
- Fixed in
- 2.8.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f2hp-qw27-8wfq lists affected ranges: Maven org.apache.storm:storm-webapp >=0 <2.8.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-35565: 0.47% estimated exploitation activity in the next 30 days; percentile 40.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Stored Cross-Site Scripting (XSS) via Unsanitized Topology Metadata in Apache Storm UI Versions Affected: before 2.8.6 Description: The Storm UI visualization component interpolates topology metadata including component IDs, stream names, and grouping values directly into HTML via innerHTML in parseNode() and parseEdge() without sanitization at any layer. An authenticated user with topology submission rights could craft a topology containing malicious HTML/JavaScript in component identifiers (e.g., a bolt ID containing an onerror event handler). This payload flows through Nimbus → Thrift → the Visualization API → vis.js tooltip rendering, resulting in stored cross-site scripting. In multi-tenant deployments where topology submission is available to less-trusted users but the UI is accessed by operators or administrators, this enables privilege escalation through script execution in an admin's browser session. Mitigation: 2.x users should upgrade to 2.8.6. Users who cannot upgrade…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f2hp-qw27-8wfq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35565 Advisory: Apache Storm UI: Stored Cross-Site Scripting (XSS) via Unsanitized Topology Metadata IDs: CVE-2026-35565, GHSA-f2hp-qw27-8wfq Record: https://patchnext.com/advisories/cve-2026-35565 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.storm:storm-webapp 2.8.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.storm:storm-webapp: affected < 2.8.6; fixed in 2.8.6 ## Suggested inspection (read-only) - Maven org.apache.storm:storm-webapp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.storm:storm-webapp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f2hp-qw27-8wfq (GitHub-reviewed advisory GHSA-f2hp-qw27-8wfq lists affected ranges: Maven org.apache.storm:storm-webapp >=0 <2.8.6) Commands are suggestions: review each one before running it.
Loading voting…