Skip to content

← Actionable
Medium, CVSS 5.4amended

Tornado has incomplete validation of cookie attributes

CVE-2026-35536GHSA-78cv-mqj4-43f7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    <= 6.5.4
    Fixed in
    6.5.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-35536: 0.25% estimated exploitation activity in the next 30 days; percentile 15.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Values passed to the domain, path, and samesite arguments of RequestHandler.setcookie were not completely validated in versions of Tornado prior to 6.5.5. In particular, semicolons would be allowed, which could be used to inject attacker-controlled values for other cookie attributes.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-78cv-mqj4-43f7

  2. Revision 2 · amended ·

    Amended from osv record GHSA-fqwm-6jpj-5wxc

  3. Revision 1 · created ·

    Published from osv record GHSA-78cv-mqj4-43f7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35536

Advisory: Tornado has incomplete validation of cookie attributes
IDs: CVE-2026-35536, GHSA-78cv-mqj4-43f7
Record: https://patchnext.com/advisories/cve-2026-35536 (revision 3, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected <= 6.5.4; fixed in 6.5.5

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-78cv-mqj4-43f7 (OSV record GHSA-78cv-mqj4-43f7 lists affected ranges: PyPI tornado >=0 <6.5.5 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-fqwm-6jpj-5wxc (OSV record GHSA-fqwm-6jpj-5wxc lists affected ranges: PyPI tornado >=0 <6.5.5 (fixed))
- Verified: https://github.com/advisories/GHSA-78cv-mqj4-43f7 (GitHub-reviewed advisory GHSA-78cv-mqj4-43f7 lists affected ranges: PyPI tornado >=0 <=6.5.4)

Commands are suggestions: review each one before running it.

Loading voting…