Skip to content

← Actionable
High, CVSS 7.7

Local settings bypass config trust checks

CVE-2026-35533GHSA-436v-8fw5-4mj8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mise 2026.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io mise

    Affected
    >= 2026.2.18, < 2026.6.4
    Fixed in
    2026.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-35533: 0.16% estimated exploitation activity in the next 30 days; percentile 5.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary mise loads trust-control settings from a local project .mise.toml before the trust check runs. An attacker who can place a malicious .mise.toml in a repository can make that same file appear trusted and then reach dangerous directives such as [env] .source, templates, hooks, or tasks. The strongest current variant is trustedconfigpaths = ["/"]. I confirmed on current v2026.3.17 in Docker that this causes an untrusted project config to become trusted during mise hook-env, which then executes an attacker-controlled .source script. The same preload issue also lets local yes = true / ci = true auto-approve trust prompts on v2026.2.18+, but the primary PoC below uses the stronger trustedconfigpaths path. Details The vulnerable load order is: 1. Settings::tryget() preloads local settings files. 2. parsesettingsfile() returns settingsfile.settings without checking whether the file is trusted. 3. trustcheck() later consults those already-loaded settings. The main trust-bypass path is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-436v-8fw5-4mj8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35533

Advisory: Local settings bypass config trust checks
IDs: CVE-2026-35533, GHSA-436v-8fw5-4mj8
Record: https://patchnext.com/advisories/cve-2026-35533 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mise 2026.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io mise: affected >= 2026.2.18, < 2026.6.4; fixed in 2026.6.4

## Suggested inspection (read-only)
- crates.io mise: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-436v-8fw5-4mj8 (GitHub-reviewed advisory GHSA-436v-8fw5-4mj8 lists affected ranges: crates.io mise >=2026.2.18 <2026.6.4)

Commands are suggestions: review each one before running it.

Loading voting…