strawberry-graphql: Authentication bypass via legacy graphql-ws WebSocket subprotocol
CVE-2026-35523GHSA-vpwc-v33q-mq89
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (strawberry-graphql 0.312.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI strawberry-graphql
- Affected
- <= 0.312.2
- Fixed in
- 0.312.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vpwc-v33q-mq89 lists affected ranges: PyPI strawberry-graphql >=0 <0.312.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vpwc-v33q-mq89 lists affected ranges: PyPI strawberry-graphql >=0 <=0.312.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-35523: 0.42% estimated exploitation activity in the next 30 days; percentile 36.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Strawberry up until version 0.312.3 is vulnerable to an authentication bypass on WebSocket subscription endpoints. The legacy graphql-ws subprotocol handler does not verify that a connectioninit handshake has been completed before processing start (subscription) messages. This allows a remote attacker to skip the onwsconnect authentication hook entirely by connecting with the graphql-ws subprotocol and sending a start message directly, without ever sending connectioninit. The graphql-transport-ws subprotocol handler is not affected, as it correctly gates subscription operations on a connectionacknowledged flag. However, both subprotocols are enabled by default in all framework integrations that support websockets, and the subprotocol is selected by the client via the Sec-WebSocket-Protocol header. Any application relying on onwsconnect for authentication or authorization is affected. Mitigation: Upgrade to the patched version, or explicitly disable the legacy graphql-ws subprotocol…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vpwc-v33q-mq89
- Revision 1 · created ·
Published from osv record GHSA-vpwc-v33q-mq89
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35523 Advisory: strawberry-graphql: Authentication bypass via legacy graphql-ws WebSocket subprotocol IDs: CVE-2026-35523, GHSA-vpwc-v33q-mq89 Record: https://patchnext.com/advisories/cve-2026-35523 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: strawberry-graphql 0.312.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI strawberry-graphql: affected <= 0.312.2; fixed in 0.312.3 ## Suggested inspection (read-only) - `python -m pip show strawberry-graphql`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on strawberry-graphql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vpwc-v33q-mq89 (OSV record GHSA-vpwc-v33q-mq89 lists affected ranges: PyPI strawberry-graphql >=0 <0.312.3 (fixed)) - Verified: https://github.com/advisories/GHSA-vpwc-v33q-mq89 (GitHub-reviewed advisory GHSA-vpwc-v33q-mq89 lists affected ranges: PyPI strawberry-graphql >=0 <=0.312.2) Commands are suggestions: review each one before running it.
Loading voting…