changedetection.io Vulnerable to Authentication Bypass via Decorator Ordering
CVE-2026-35490GHSA-jmrh-xmgh-x9j4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.54.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI changedetection-io
- Affected
- <= 0.54.7
- Fixed in
- 0.54.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jmrh-xmgh-x9j4 lists affected ranges: PyPI changedetection-io >=0 <=0.54.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jmrh-xmgh-x9j4 lists affected ranges: PyPI changedetection-io >=0 <0.54.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-35490: 0.54% estimated exploitation activity in the next 30 days; percentile 45.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary On 13 routes across 5 blueprint files, the @loginoptionallyrequired decorator is placed before (outer to) @blueprint.route() instead of after it. In Flask, @route() must be the outermost decorator because it registers the function it receives. When the order is reversed, @route() registers the original undecorated function, and the auth wrapper is never in the call chain. This silently disables authentication on these routes. The developer correctly uses the decorator on 30+ other routes with the proper order, making this a classic consistency gap. Details Correct order (used on 30+ routes): Incorrect order (13 vulnerable routes): POC Impact - Complete data exfiltration — Backups contain all monitored URLs, notification webhook URLs (which may contain API tokens for Slack, Discord, etc.), and configuration - Backup restore = config injection — Attacker can upload a malicious backup with crafted watch configs - SSRF — Proxy check endpoint can be triggered to scan internal…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jmrh-xmgh-x9j4
- Revision 2 · amended ·
Amended from osv record GHSA-jmrh-xmgh-x9j4
- Revision 1 · created ·
Published from ghsa record GHSA-jmrh-xmgh-x9j4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35490 Advisory: changedetection.io Vulnerable to Authentication Bypass via Decorator Ordering IDs: CVE-2026-35490, GHSA-jmrh-xmgh-x9j4 Record: https://patchnext.com/advisories/cve-2026-35490 (revision 3, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.54.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI changedetection-io: affected <= 0.54.7; fixed in 0.54.8 ## Suggested inspection (read-only) - `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on changedetection-io. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jmrh-xmgh-x9j4 (GitHub-reviewed advisory GHSA-jmrh-xmgh-x9j4 lists affected ranges: PyPI changedetection-io >=0 <=0.54.7) - Verified: https://osv.dev/vulnerability/GHSA-jmrh-xmgh-x9j4 (OSV record GHSA-jmrh-xmgh-x9j4 lists affected ranges: PyPI changedetection-io >=0 <0.54.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…