OpenSTAManager has a SQL Injection via righe Parameter in confronta_righe Modals
CVE-2026-35470GHSA-mmm5-3g4x-qw39
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devcode-it/openstamanager 2.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist devcode-it/openstamanager
- Affected
- <= 2.10.1
- Fixed in
- 2.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mmm5-3g4x-qw39 lists affected ranges: Packagist devcode-it/openstamanager >=0 <=2.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-35470: 0.42% estimated exploitation activity in the next 30 days; percentile 36.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Six confrontarighe.php files across different modules in OpenSTAManager <= 2.10.1 contain an SQL Injection vulnerability. The righe parameter received via $GET['righe'] is directly concatenated into an SQL query without any sanitization, parameterization or validation. An authenticated attacker can inject arbitrary SQL statements to extract sensitive data from the database, including user credentials, customer information, invoice data and any other stored data. Affected Files All 6 vulnerable files share the same code pattern: |
| File | Line | Affected Table | |---|------|------|----------------| | 1 | modules/fatture/modals/confrontarighe.php | 29 | corighedocumenti | | 2 | modules/interventi/modals/confrontarighe.php | 29 | inrigheinterventi | | 3 | modules/preventivi/modals/confrontarighe.php | 28 | corighepreventivi | | 4 | modules/ordini/modals/confrontarighe.php | 29 | orrigheordini | | 5 | modules/ddt/modals/confrontarighe.php | 29 | dtrigheddt | | 6 |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mmm5-3g4x-qw39
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35470 Advisory: OpenSTAManager has a SQL Injection via righe Parameter in confronta_righe Modals IDs: CVE-2026-35470, GHSA-mmm5-3g4x-qw39 Record: https://patchnext.com/advisories/cve-2026-35470 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devcode-it/openstamanager 2.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist devcode-it/openstamanager: affected <= 2.10.1; fixed in 2.10.2 ## Suggested inspection (read-only) - Packagist devcode-it/openstamanager: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devcode-it/openstamanager. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mmm5-3g4x-qw39 (GitHub-reviewed advisory GHSA-mmm5-3g4x-qw39 lists affected ranges: Packagist devcode-it/openstamanager >=0 <=2.10.1) Commands are suggestions: review each one before running it.
Loading voting…