Winter: Authenticated backend users can bypass Users controller permission checks
CVE-2026-35445GHSA-j5jq-cr68-v2xx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist winter/wn-backend-module
- Affected
- <= 1.2.12
- Fixed in
- 1.2.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j5jq-cr68-v2xx lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j5jq-cr68-v2xx lists affected ranges: Packagist winter/wn-backend-module >=0 <=1.2.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2026-35445: 0.44% estimated exploitation activity in the next 30 days; percentile 38.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Affected versions of Winter CMS did not validate the handler name submitted through the form postback mechanism (handler POST field) in the same way as AJAX requests (XWINTERREQUESTHANDLER header). The AJAX path validates that handler names match the on[A-Z][\w+] pattern, but the postback path passed the handler name directly to the handler dispatcher with no validation. This allowed an authenticated backend user to call any method on a controller — including action-prefixed, protected, and private methods — by submitting a crafted POST request with a handler field, as long as the controller either: - Contains a publicly available action via the $publicActions property, or - Degrades or removes the $requiredPermissions check in its constructor based on a condition The backend's own Users controller was affected by the second scenario: it set $requiredPermissions to null for the myaccount action, allowing any authenticated backend user to access the controller without the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j5jq-cr68-v2xx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j5jq-cr68-v2xx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35445 Advisory: Winter: Authenticated backend users can bypass Users controller permission checks IDs: CVE-2026-35445, GHSA-j5jq-cr68-v2xx Record: https://patchnext.com/advisories/cve-2026-35445 (revision 3, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist winter/wn-backend-module: affected <= 1.2.12; fixed in 1.2.13 ## Suggested inspection (read-only) - Packagist winter/wn-backend-module: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on winter/wn-backend-module. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j5jq-cr68-v2xx (OSV record GHSA-j5jq-cr68-v2xx lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.13 (fixed)) - Verified: https://github.com/advisories/GHSA-j5jq-cr68-v2xx (GitHub-reviewed advisory GHSA-j5jq-cr68-v2xx lists affected ranges: Packagist winter/wn-backend-module >=0 <=1.2.12) Commands are suggestions: review each one before running it.
Loading voting…