Skip to content

← Actionable
High, CVSS 8.1amended

Directus: Authenticated Users Can Extract Concealed Fields via Aggregate Queries

CVE-2026-35442GHSA-38hg-ww64-rrwc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 11.17.0
    Fixed in
    11.17.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-35442: 0.34% estimated exploitation activity in the next 30 days; percentile 27.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Aggregate functions (min, max) applied to fields with the conceal special type incorrectly return raw database values instead of the masked placeholder. When combined with groupBy, any authenticated user with read access to the affected collection can extract concealed field values, including static API tokens and two-factor authentication secrets from directususers. Details Fields marked with conceal are protected by payload processing logic that replaces real values with a masked placeholder on read. This protection works correctly for standard item queries, but aggregate query results are structured differently, operations are nested under their function name rather than appearing as flat field keys. The masking logic does not account for this nested structure, causing it to silently skip concealed fields in aggregate responses and return their raw values to the client. Impact - Account Takeover An authenticated attacker can harvest static API tokens for all users,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-38hg-ww64-rrwc

  2. Revision 1 · created ·

    Published from osv record GHSA-38hg-ww64-rrwc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35442

Advisory: Directus: Authenticated Users Can Extract Concealed Fields via Aggregate Queries
IDs: CVE-2026-35442, GHSA-38hg-ww64-rrwc
Record: https://patchnext.com/advisories/cve-2026-35442 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 11.17.0; fixed in 11.17.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-38hg-ww64-rrwc (OSV record GHSA-38hg-ww64-rrwc lists affected ranges: npm directus >=0 <11.17.0 (fixed))
- Verified: https://github.com/advisories/GHSA-38hg-ww64-rrwc (GitHub-reviewed advisory GHSA-38hg-ww64-rrwc lists affected ranges: npm directus >=0 <11.17.0)

Commands are suggestions: review each one before running it.

Loading voting…