Skip to content

← Actionable
Medium, CVSS 6.5amended

Directus: GraphQL Alias Amplification Denial of Service Due to Missing Query Cost/Complexity Limits

CVE-2026-35441GHSA-ph52-67fq-75wj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 11.17.0
    Fixed in
    11.17.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-35441: 0.37% estimated exploitation activity in the next 30 days; percentile 30.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Directus' GraphQL endpoints (/graphql and /graphql/system) did not deduplicate resolver invocations within a single request. An authenticated user could exploit GraphQL aliasing to repeat an expensive relational query many times in a single request, forcing the server to execute a large number of independent complex database queries concurrently, multiplying database load linearly with the number of aliases. The existing token limit on GraphQL queries still permitted enough aliases for significant resource exhaustion, while the relational depth limit applied per alias without reducing the total number executed. Rate limiting is disabled by default, meaning no built-in throttle prevented this from causing CPU, memory, and I/O exhaustion that could degrade or crash the service. Any authenticated user, including those with minimal read-only permissions, could trigger this condition. Fix A request-scoped resolver deduplication mechanism was introduced and applied broadly across…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ph52-67fq-75wj

  2. Revision 1 · created ·

    Published from osv record GHSA-ph52-67fq-75wj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35441

Advisory: Directus: GraphQL Alias Amplification Denial of Service Due to Missing Query Cost/Complexity Limits
IDs: CVE-2026-35441, GHSA-ph52-67fq-75wj
Record: https://patchnext.com/advisories/cve-2026-35441 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 11.17.0; fixed in 11.17.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ph52-67fq-75wj (OSV record GHSA-ph52-67fq-75wj lists affected ranges: npm directus >=0 <11.17.0 (fixed))
- Verified: https://github.com/advisories/GHSA-ph52-67fq-75wj (GitHub-reviewed advisory GHSA-ph52-67fq-75wj lists affected ranges: npm directus >=0 <11.17.0)

Commands are suggestions: review each one before running it.

Loading voting…