Skip to content

← Actionable
Low, CVSS 2.3amended

Neo4j Labs MCP Servers: SSRF and Data Modification via read_only Mode Bypass Through CALL Procedures

CVE-2026-35402GHSA-x3cv-r3g3-fpg9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-neo4j-cypher 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-35402: 0.26% estimated exploitation activity in the next 30 days; percentile 18.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The readonly mode in mcp-neo4j-cypher versions prior to 0.6.0 can be bypassed using CALL procedures. Details Impact The enforcing of readonly mode in vulnerable versions could be bypassed by certain APOC procedures. Patches v0.6.0 release hardened the checks around the mode. The only way to guarantee the server actions is to limit the permissions of the db credentials available to the server. Notes Impacts for server-side request forgery vulnerabilities may depend on both the configuration of the vulnerable system as well as the presence of other systems in the environment that could be accessed as part of exploitation. Recommended hardening - Limit the apoc procedures to what's required - Manage data loading privileges - Don't relax the default settings without compensating controls - apoc.import.file.enabled is false by default - apoc.import.file.useneo4jconfig is true by default to restrict file imports to the import folder Credits We want to publicly recognise the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x3cv-r3g3-fpg9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x3cv-r3g3-fpg9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35402

Advisory: Neo4j Labs MCP Servers: SSRF and Data Modification via read_only Mode Bypass Through CALL Procedures
IDs: CVE-2026-35402, GHSA-x3cv-r3g3-fpg9
Record: https://patchnext.com/advisories/cve-2026-35402 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-neo4j-cypher 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-neo4j-cypher: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- `python -m pip show mcp-neo4j-cypher`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-neo4j-cypher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x3cv-r3g3-fpg9 (OSV record GHSA-x3cv-r3g3-fpg9 lists affected ranges: PyPI mcp-neo4j-cypher >=0 <0.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x3cv-r3g3-fpg9 (GitHub-reviewed advisory GHSA-x3cv-r3g3-fpg9 lists affected ranges: PyPI mcp-neo4j-cypher >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…