Skip to content

← Actionable
High, CVSS 7.6amended

Jupyter Server: Path Traversal via incorrect startswith() root directory check allows access to sibling directories

CVE-2026-35397GHSA-5789-5fc7-67v3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-35397: 0.62% estimated exploitation activity in the next 30 days; percentile 49.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Jupyter Server <=2.17.0 can access directories sibling to the root directory, if it starts with the root dir's name. PoC Minimal: Full PoC by @stef41: https://gist.github.com/Yann-P/66d4982a965dee8fcb8dd89db29e7006 Impact It is possible for an authenticated user to access content outside the server's rootdir in siblings directories sharing the same prefix as the rootdir. The attacker can escalate access, reading, writing, and deleting from sibling directories. This can have a tangible impact for deployments using predictable naming scheme with multi-tenant server, for example user1, user2, user3, ..., user10 etc, as user1 could access and modify files of all user10 - user19 and higher. In a hypothetical system where users can choose a name of their folder, an attacker could choose a single-letter username to gain access to a significant number of sibling directories. Workarounds Use folder names that do not overlap. Acknowledgments Thank you to @stef41 for providing a useful…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5789-5fc7-67v3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5789-5fc7-67v3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35397

Advisory: Jupyter Server: Path Traversal via incorrect startswith() root directory check allows access to sibling directories
IDs: CVE-2026-35397, GHSA-5789-5fc7-67v3
Record: https://patchnext.com/advisories/cve-2026-35397 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyter-server: affected <= 2.17.0; fixed in 2.18.0

## Suggested inspection (read-only)
- `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyter-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5789-5fc7-67v3 (OSV record GHSA-5789-5fc7-67v3 lists affected ranges: PyPI jupyter-server >=0 <2.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5789-5fc7-67v3 (GitHub-reviewed advisory GHSA-5789-5fc7-67v3 lists affected ranges: PyPI jupyter-server >=0 <=2.17.0)

Commands are suggestions: review each one before running it.

Loading voting…