Skip to content

← Actionable
Medium, CVSS 5.5

uutils coreutils has an Improper Input Validation Issue in its cut Utility

CVE-2026-35380GHSA-m2pg-c7m6-77pj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (coreutils 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io coreutils

    Affected
    < 0.8.0
    Fixed in
    0.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-35380: 0.16% estimated exploitation activity in the next 30 days; percentile 4.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A logic error in the cut utility of uutils coreutils causes the program to incorrectly interpret the literal two-byte string '' (two single quotes) as an empty delimiter. The implementation mistakenly maps this string to the NUL character for both the -d (delimiter) and --output-delimiter options. This vulnerability can lead to silent data corruption or logic errors in automated scripts and data pipelines that process strings containing these characters, as the utility may unintentionally split or join data on NUL bytes rather than the intended literal characters.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m2pg-c7m6-77pj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35380

Advisory: uutils coreutils has an Improper Input Validation Issue in its cut Utility
IDs: CVE-2026-35380, GHSA-m2pg-c7m6-77pj
Record: https://patchnext.com/advisories/cve-2026-35380 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: coreutils 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io coreutils: affected < 0.8.0; fixed in 0.8.0

## Suggested inspection (read-only)
- crates.io coreutils: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on coreutils.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m2pg-c7m6-77pj (GitHub-reviewed advisory GHSA-m2pg-c7m6-77pj lists affected ranges: crates.io coreutils >=0 <0.8.0)

Commands are suggestions: review each one before running it.

Loading voting…