Skip to content

← Actionable
Medium, CVSS 4.4

id: groups= computed from real GID instead of effective GID

CVE-2026-35370GHSA-47c7-qrm7-mqw7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uu_id 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io uu_id

    Affected
    < 0.6.0
    Fixed in
    0.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-35370: 0.11% estimated exploitation activity in the next 30 days; percentile 1.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The id utility in uutils coreutils miscalculates the groups= section of its output. The implementation uses a user's real GID instead of their effective GID to compute the group list, leading to potentially divergent output compared to GNU coreutils. Because many scripts and automated processes rely on the output of id to make security-critical access-control or permission decisions, this discrepancy can lead to unauthorized access or security misconfigurations. --- Zellic finding 3.72. Reported in the Zellic uutils coreutils Program Security Assessment (for Canonical, Jan 2026), audited commit 3a07ffc5a9bd4c283e75afa548ba1f1957bad242.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-47c7-qrm7-mqw7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35370

Advisory: id: groups= computed from real GID instead of effective GID
IDs: CVE-2026-35370, GHSA-47c7-qrm7-mqw7
Record: https://patchnext.com/advisories/cve-2026-35370 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uu_id 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io uu_id: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- crates.io uu_id: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uu_id.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-47c7-qrm7-mqw7 (GitHub-reviewed advisory GHSA-47c7-qrm7-mqw7 lists affected ranges: crates.io uu_id >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…