Skip to content

← Actionable
Medium, CVSS 5.5

kill: 'kill -1' parsed as PID -1, sending SIGTERM to all processes (system crash / DoS)

CVE-2026-35369GHSA-p6rv-2qpm-fwvg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uu_kill 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io uu_kill

    Affected
    < 0.6.0
    Fixed in
    0.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-35369: 0.13% estimated exploitation activity in the next 30 days; percentile 2.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

kill -1 is incorrectly parsed as a positional pid = -1; combined with the default SIGTERM this calls kill(-1, SIGTERM), signaling nearly every process the caller can see. GNU kill recognizes -1/-9 as signals and reports "not enough arguments". Impact: a user running kill -1 mass-terminates processes, potentially crashing the system. Recommendation: parse -N as a signal number, and error with "not enough arguments" when no PID is given. Remediation: Acknowledged by Canonical; fixed in commit cae94028. --- Reported by Zellic in the uutils coreutils Program Security Assessment (prepared for Canonical, Jan 20 2026), audited commit 3a07ffc5a9bd4c283e75afa548ba1f1957bad242. Finding 3.70. Credit: Zellic.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p6rv-2qpm-fwvg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35369

Advisory: kill: 'kill -1' parsed as PID -1, sending SIGTERM to all processes (system crash / DoS)
IDs: CVE-2026-35369, GHSA-p6rv-2qpm-fwvg
Record: https://patchnext.com/advisories/cve-2026-35369 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uu_kill 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io uu_kill: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- crates.io uu_kill: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uu_kill.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p6rv-2qpm-fwvg (GitHub-reviewed advisory GHSA-p6rv-2qpm-fwvg lists affected ranges: crates.io uu_kill >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…