Skip to content

← Actionable
Medium, CVSS 4.4

printenv: environment variables with invalid UTF-8 are silently skipped (evades inspection)

CVE-2026-35366GHSA-p7h3-7q52-72w8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uu_printenv 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-35366: 0.17% estimated exploitation activity in the next 30 days; percentile 6.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The printenv utility in uutils coreutils fails to display environment variables containing invalid UTF-8 byte sequences. While POSIX permits arbitrary bytes in environment strings, the uutils implementation silently skips these entries rather than printing the raw bytes. This vulnerability allows malicious environment variables (e.g., adversarial LDPRELOAD values) to evade inspection by administrators or security auditing tools, potentially allowing library injection or other environment-based attacks to go undetected. --- Zellic finding 3.66. Reported in the Zellic uutils coreutils Program Security Assessment (for Canonical, Jan 2026), audited commit 3a07ffc5a9bd4c283e75afa548ba1f1957bad242.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p7h3-7q52-72w8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35366

Advisory: printenv: environment variables with invalid UTF-8 are silently skipped (evades inspection)
IDs: CVE-2026-35366, GHSA-p7h3-7q52-72w8
Record: https://patchnext.com/advisories/cve-2026-35366 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uu_printenv 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io uu_printenv: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- crates.io uu_printenv: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uu_printenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p7h3-7q52-72w8 (GitHub-reviewed advisory GHSA-p7h3-7q52-72w8 lists affected ranges: crates.io uu_printenv >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…