Skip to content

← Actionable
Low, CVSS 3.6

uucore: safe_traversal TOCTOU protection only enabled on Linux

CVE-2026-35362GHSA-w6xc-g9qj-vp32

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uucore 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io uucore

    Affected
    < 0.6.0
    Fixed in
    0.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.6 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-35362: 0.18% estimated exploitation activity in the next 30 days; percentile 7.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The safetraversal module in uutils coreutils, which provides protection against Time-of-Check to Time-of-Use (TOCTOU) symlink races using file-descriptor-relative syscalls, is incorrectly limited to Linux targets. On other Unix-like systems such as macOS and FreeBSD, the utility fails to utilize these protections, leaving directory traversal operations vulnerable to symlink race conditions. --- Zellic finding 3.59. Reported in the Zellic uutils coreutils Program Security Assessment (for Canonical, Jan 2026), audited commit 3a07ffc5a9bd4c283e75afa548ba1f1957bad242.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w6xc-g9qj-vp32

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35362

Advisory: uucore: safe_traversal TOCTOU protection only enabled on Linux
IDs: CVE-2026-35362, GHSA-w6xc-g9qj-vp32
Record: https://patchnext.com/advisories/cve-2026-35362 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uucore 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io uucore: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- crates.io uucore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uucore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w6xc-g9qj-vp32 (GitHub-reviewed advisory GHSA-w6xc-g9qj-vp32 lists affected ranges: crates.io uucore >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…