Skip to content

← Actionable
Critical, CVSS 9.0amended

Budibase: Unauthenticated Remote Code Execution via Webhook Trigger and Bash Automation Step

CVE-2026-35216GHSA-fcm4-4pj2-m5hf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.33.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-35216: 10.90% estimated exploitation activity in the next 30 days; percentile 95.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated attacker can achieve Remote Code Execution (RCE) on the Budibase server by triggering an automation that contains a Bash step via the public webhook endpoint. No authentication is required to trigger the exploit. The process executes as root inside the container. Details Vulnerable endpoint — packages/server/src/api/routes/webhook.ts line 13: The webhook trigger endpoint is registered on publicRoutes with no authentication middleware. Any unauthenticated HTTP client can POST to this endpoint. Vulnerable sink — packages/server/src/automations/steps/bash.ts lines 21–26: The Bash automation step uses Handlebars template processing (processStringSync) on inputs.code, substituting values from the webhook request body into the shell command string before passing it to execSync(). Attack chain: Precondition: An admin must have created and published an automation containing: 1. A Webhook trigger 2. A Bash step whose code field uses a trigger field template (e.g.,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fcm4-4pj2-m5hf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-fcm4-4pj2-m5hf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-fcm4-4pj2-m5hf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35216

Advisory: Budibase: Unauthenticated Remote Code Execution via Webhook Trigger and Bash Automation Step
IDs: CVE-2026-35216, GHSA-fcm4-4pj2-m5hf
Record: https://patchnext.com/advisories/cve-2026-35216 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.33.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.33.4; fixed in 3.33.4

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fcm4-4pj2-m5hf (GitHub-reviewed advisory GHSA-fcm4-4pj2-m5hf lists affected ranges: npm @budibase/server >=0 <3.33.4)
- Verified: https://osv.dev/vulnerability/GHSA-fcm4-4pj2-m5hf (OSV record GHSA-fcm4-4pj2-m5hf lists affected ranges: npm @budibase/server >=0 <3.33.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…