Skip to content

← Actionable
High, CVSS 8.7amended

Budibase: Path traversal in plugin file upload enables arbitrary directory deletion and file write

CVE-2026-35214GHSA-2wfh-rcwf-wh23

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.33.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H
EPSS
  • CVE-2026-35214: 0.56% estimated exploitation activity in the next 30 days; percentile 46.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The plugin file upload endpoint (POST /api/plugin/upload) passes the user-supplied filename directly to createTempFolder() without sanitizing path traversal sequences. An attacker with Global Builder privileges can craft a multipart upload with a filename containing ../ to delete arbitrary directories via rmSync and write arbitrary files via tarball extraction to any filesystem path the Node.js process can access. Severity - Attack Vector: Network — exploitable via the plugin upload HTTP API - Attack Complexity: Low — no special conditions; a single crafted multipart request suffices - Privileges Required: High — requires Global Builder role (GLOBALBUILDER permission) - User Interaction: None - Scope: Changed — the plugin upload feature is scoped to a temp directory, but the traversal escapes to the host filesystem - Confidentiality Impact: None — the vulnerability enables deletion and writing, not reading - Integrity Impact: High — attacker can delete arbitrary directories…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2wfh-rcwf-wh23

  2. Revision 1 · created ·

    Published from osv record GHSA-2wfh-rcwf-wh23

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35214

Advisory: Budibase: Path traversal in plugin file upload enables arbitrary directory deletion and file write
IDs: CVE-2026-35214, GHSA-2wfh-rcwf-wh23
Record: https://patchnext.com/advisories/cve-2026-35214 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.33.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.33.4; fixed in 3.33.4

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2wfh-rcwf-wh23 (OSV record GHSA-2wfh-rcwf-wh23 lists affected ranges: npm @budibase/server >=0 <3.33.4 (fixed))
- Verified: https://github.com/advisories/GHSA-2wfh-rcwf-wh23 (GitHub-reviewed advisory GHSA-2wfh-rcwf-wh23 lists affected ranges: npm @budibase/server >=0 <3.33.4)

Commands are suggestions: review each one before running it.

Loading voting…