Parse Server: File upload Content-Type override via extension mismatch
CVE-2026-35200GHSA-vr5f-2r24-w5hc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.7.1-alpha.4, 8.6.73), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.7.1-alpha.4<= 8.6.72
- Fixed in
- 8.6.73, 9.7.1-alpha.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vr5f-2r24-w5hc lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.73 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vr5f-2r24-w5hc lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.72
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-35200: 0.17% estimated exploitation activity in the next 30 days; percentile 6.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A file can be uploaded with a filename extension that passes the file extension allowlist (e.g., .txt) but with a Content-Type header that differs from the extension (e.g., text/html). The Content-Type is passed to the storage adapter without consistency validation. Storage adapters that store and serve the provided Content-Type (such as S3 or GCS) serve the file with the mismatched Content-Type. The default GridFS adapter is not affected because it derives Content-Type from the filename at serving time. Patches The file upload now derives the Content-Type from the filename extension, overriding any user-provided Content-Type when the file has an extension. Workarounds Configure the storage adapter or CDN to derive Content-Type from the filename extension instead of using the stored Content-Type.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vr5f-2r24-w5hc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vr5f-2r24-w5hc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35200 Advisory: Parse Server: File upload Content-Type override via extension mismatch IDs: CVE-2026-35200, GHSA-vr5f-2r24-w5hc Record: https://patchnext.com/advisories/cve-2026-35200 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.7.1-alpha.4, 8.6.73. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.7.1-alpha.4; <= 8.6.72; fixed in 8.6.73, 9.7.1-alpha.4 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vr5f-2r24-w5hc (OSV record GHSA-vr5f-2r24-w5hc lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.73 (fixed)) - Verified: https://github.com/advisories/GHSA-vr5f-2r24-w5hc (GitHub-reviewed advisory GHSA-vr5f-2r24-w5hc lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.72) Commands are suggestions: review each one before running it.
Loading voting…