Apache Flink: Remote code execution via SQL injection in code generation
CVE-2026-35194GHSA-2f54-v4hm-fx73
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.flink:flink-table-planner_2.12 2.2.1, 2.1.2, 2.0.2, 1.20.4; org.apache.flink:flink-table-runtime 2.2.1, 2.1.2, 2.0.2, 1.20.4; org.apache.flink:flink-table-api-java 2.2.1, 2.1.2, 2.0.2, 1.20.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.flink:flink-table-planner_2.12
- Affected
- >= 1.15.0, < 1.20.4>= 2.0.0, < 2.0.2>= 2.1.0, < 2.1.2>= 2.2.0, < 2.2.1
- Fixed in
- 1.20.4, 2.1.2, 2.0.2, 2.2.1
Maven org.apache.flink:flink-table-runtime
- Affected
- >= 1.15.0, < 1.20.4>= 2.0.0, < 2.0.2>= 2.1.0, < 2.1.2>= 2.2.0, < 2.2.1
- Fixed in
- 1.20.4, 2.1.2, 2.0.2, 2.2.1
Maven org.apache.flink:flink-table-api-java
- Affected
- >= 1.15.0, < 1.20.4>= 2.0.0, < 2.0.2>= 2.1.0, < 2.1.2>= 2.2.0, < 2.2.1
- Fixed in
- 1.20.4, 2.1.2, 2.0.2, 2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2f54-v4hm-fx73 lists affected ranges: Maven org.apache.flink:flink-table-planner_2.12 >=1.15.0 =2.0.0 =2.1.0 =2.2.0 =1.15.0 =2.0.0 =2.1.0 =2.2.0 =1.15.0 =2.0.0 =2.1.0 =2.2.0 <2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-35194: 0.38% estimated exploitation activity in the next 30 days; percentile 32.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Code injection in SQL code generation in Apache Flink 1.15.0 through 1.20.x and 2.0.0 through 2.x allows authenticated users with query submission privileges to execute arbitrary code on TaskManagers via maliciously crafted SQL queries. The vulnerability affects JSON functions (1.15.0+) and LIKE expressions with ESCAPE clauses (1.17.0+). User-controlled strings are interpolated into generated Java code without proper escaping, allowing attackers to break out of string literals and inject arbitrary expressions. Users are recommended to upgrade to either version 1.20.4, 2.0.2, 2.1.2 or 2.2.1, which fixes this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2f54-v4hm-fx73
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35194 Advisory: Apache Flink: Remote code execution via SQL injection in code generation IDs: CVE-2026-35194, GHSA-2f54-v4hm-fx73 Record: https://patchnext.com/advisories/cve-2026-35194 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.flink:flink-table-planner_2.12 2.2.1, 2.1.2, 2.0.2, 1.20.4; org.apache.flink:flink-table-runtime 2.2.1, 2.1.2, 2.0.2, 1.20.4; org.apache.flink:flink-table-api-java 2.2.1, 2.1.2, 2.0.2, 1.20.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.flink:flink-table-planner_2.12: affected >= 1.15.0, < 1.20.4; >= 2.0.0, < 2.0.2; >= 2.1.0, < 2.1.2; >= 2.2.0, < 2.2.1; fixed in 1.20.4, 2.1.2, 2.0.2, 2.2.1 - Maven org.apache.flink:flink-table-runtime: affected >= 1.15.0, < 1.20.4; >= 2.0.0, < 2.0.2; >= 2.1.0, < 2.1.2; >= 2.2.0, < 2.2.1; fixed in 1.20.4, 2.1.2, 2.0.2, 2.2.1 - Maven org.apache.flink:flink-table-api-java: affected >= 1.15.0, < 1.20.4; >= 2.0.0, < 2.0.2; >= 2.1.0, < 2.1.2; >= 2.2.0, < 2.2.1; fixed in 1.20.4, 2.1.2, 2.0.2, 2.2.1 ## Suggested inspection (read-only) - Maven org.apache.flink:flink-table-planner_2.12: check the installed version with your package manager. - Maven org.apache.flink:flink-table-runtime: check the installed version with your package manager. - Maven org.apache.flink:flink-table-api-java: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.flink:flink-table-planner_2.12, org.apache.flink:flink-table-runtime, org.apache.flink:flink-table-api-java. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2f54-v4hm-fx73 (GitHub-reviewed advisory GHSA-2f54-v4hm-fx73 lists affected ranges: Maven org.apache.flink:flink-table-planner_2.12 >=1.15.0 =2.0.0 =2.1.0 =2.2.0 =1.15.0 =2.0.0 =2.1.0 =2.2.0 =1.15.0 =2.0.0 =2.1.0 =2.2.0 <2.2.1) Commands are suggestions: review each one before running it.
Loading voting…