Skip to content

← Actionable
Critical, CVSS 9.8amended

Kedro has Arbitrary Code Execution via Malicious Logging Configuration

CVE-2026-35171GHSA-9cqf-439c-j96r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kedro 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI kedro

    Affected
    < 1.3.0
    Fixed in
    1.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-35171: 0.73% estimated exploitation activity in the next 30 days; percentile 54.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is a critical remote code execution (RCE) vulnerability caused by unsafe use of logging.config.dictConfig() with user-controlled input. Kedro allows the logging configuration file path to be set via the KEDROLOGGINGCONFIG environment variable and loads it without validation. The logging configuration schema supports the special () key, which enables arbitrary callable instantiation. An attacker can exploit this to execute arbitrary system commands during application startup. --- Patches The vulnerability is fixed by introducing validation that rejects the unsafe () factory key in logging configurations before passing them to dictConfig(). Fixed in - Kedro 1.3.0 Users should upgrade to this version as soon as possible. --- Workarounds If upgrading is not immediately possible: - Do not allow untrusted input to control the KEDROLOGGINGCONFIG environment variable - Restrict write access to logging configuration files - Avoid using externally supplied or dynamically generated…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9cqf-439c-j96r

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9cqf-439c-j96r

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9cqf-439c-j96r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35171

Advisory: Kedro has Arbitrary Code Execution via Malicious Logging Configuration
IDs: CVE-2026-35171, GHSA-9cqf-439c-j96r
Record: https://patchnext.com/advisories/cve-2026-35171 (revision 3, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kedro 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI kedro: affected < 1.3.0; fixed in 1.3.0

## Suggested inspection (read-only)
- `python -m pip show kedro`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kedro.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9cqf-439c-j96r (GitHub-reviewed advisory GHSA-9cqf-439c-j96r lists affected ranges: PyPI kedro >=0 <1.3.0)
- Verified: https://osv.dev/vulnerability/GHSA-9cqf-439c-j96r (OSV record GHSA-9cqf-439c-j96r lists affected ranges: PyPI kedro >=0 <1.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…