Skip to content

← Actionable
High, CVSS 8.8

OpenSTAManager: SQL Injection via Aggiornamenti Module

CVE-2026-35168GHSA-2fr7-cc4f-wh98

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (devcode-it/openstamanager 2.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-35168: 0.68% estimated exploitation activity in the next 30 days; percentile 52.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The Aggiornamenti (Updates) module in OpenSTAManager <= 2.10.1 contains a database conflict resolution feature (op=risolvi-conflitti-database) that accepts a JSON array of SQL statements via POST and executes them directly against the database without any validation, allowlist, or sanitization. An authenticated attacker with access to the Aggiornamenti module can execute arbitrary SQL statements including CREATE, DROP, ALTER, INSERT, UPDATE, DELETE, SELECT INTO OUTFILE, and any other SQL command supported by the MySQL server. Foreign key checks are explicitly disabled before execution (SET FOREIGNKEYCHECKS=0), further reducing database integrity protections. Affected Code File: modules/aggiornamenti/actions.php, lines 40-82 Key Issues 1. No query validation: The SQL statements from user input are executed directly via $dbo-query() without any validation or filtering. 2. No allowlist: There is no restriction on which SQL commands are permitted (e.g., only ALTER TABLE or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2fr7-cc4f-wh98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35168

Advisory: OpenSTAManager: SQL Injection via Aggiornamenti Module
IDs: CVE-2026-35168, GHSA-2fr7-cc4f-wh98
Record: https://patchnext.com/advisories/cve-2026-35168 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: devcode-it/openstamanager 2.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist devcode-it/openstamanager: affected <= 2.10.1; fixed in 2.10.2

## Suggested inspection (read-only)
- Packagist devcode-it/openstamanager: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on devcode-it/openstamanager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2fr7-cc4f-wh98 (GitHub-reviewed advisory GHSA-2fr7-cc4f-wh98 lists affected ranges: Packagist devcode-it/openstamanager >=0 <=2.10.1)

Commands are suggestions: review each one before running it.

Loading voting…