OctoPrint has XSS in its Suppressed Command Notifications
CVE-2026-35163GHSA-p6qx-ghxm-389h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 2.0.0rc3, 1.11.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- <= 1.11.7>= 2.0.0rc1, <= 2.0.0rc2
- Fixed in
- 1.11.8, 2.0.0rc3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p6qx-ghxm-389h lists affected ranges: PyPI octoprint >=0 =2.0.0rc1 <2.0.0rc3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p6qx-ghxm-389h lists affected ranges: PyPI octoprint >=0 =2.0.0rc1 <=2.0.0rc2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-35163: 0.20% estimated exploitation activity in the next 30 days; percentile 9.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OctoPrint versions up to and including 1.11.7 as well as 2.0.0rc1 and 2.0.0rc2 are affected by a vulnerability that allows injection of arbitrary HTML and JavaScript into Suppressed Command notifications popups generated by the printer. An attacker who successfully convinces a victim to print a specially crafted file could exploit this issue to disrupt ongoing prints, extract information (including sensitive configuration settings, if the targeted user has the necessary permissions for that), or perform other actions on behalf of the targeted user within the OctoPrint instance. Patches The vulnerability has been patched in version 1.11.8 and 2.0.0rc3. Workaround OctoPrint administrators can mitigate the risk by disabling popups: - for Action Command notifications, set OctoPrint Settings - Serial Connection - Behaviour - Sanity Checking - Display notifications for suppressed commands to Never show notifications It is also strongly recommended to ensure that files being printed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p6qx-ghxm-389h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p6qx-ghxm-389h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35163 Advisory: OctoPrint has XSS in its Suppressed Command Notifications IDs: CVE-2026-35163, GHSA-p6qx-ghxm-389h Record: https://patchnext.com/advisories/cve-2026-35163 (revision 3, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 2.0.0rc3, 1.11.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected <= 1.11.7; >= 2.0.0rc1, <= 2.0.0rc2; fixed in 1.11.8, 2.0.0rc3 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p6qx-ghxm-389h (OSV record GHSA-p6qx-ghxm-389h lists affected ranges: PyPI octoprint >=0 =2.0.0rc1 <2.0.0rc3 (fixed)) - Verified: https://github.com/advisories/GHSA-p6qx-ghxm-389h (GitHub-reviewed advisory GHSA-p6qx-ghxm-389h lists affected ranges: PyPI octoprint >=0 =2.0.0rc1 <=2.0.0rc2) Commands are suggestions: review each one before running it.
Loading voting…