Skip to content

← Actionable
High, CVSS 8.8amended

BentoML: SSTI via Unsandboxed Jinja2 in Dockerfile Generation

CVE-2026-35044GHSA-v959-cwq9-7hr6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bentoml 1.4.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bentoml

    Affected
    <= 1.4.37
    Fixed in
    1.4.38

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-35044: 0.40% estimated exploitation activity in the next 30 days; percentile 34.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Dockerfile generation function generatecontainerfile() in src/bentoml/internal/container/generate.py uses an unsandboxed jinja2.Environment with the jinja2.ext.do extension to render user-provided dockerfiletemplate files. When a victim imports a malicious bento archive and runs bentoml containerize, attacker-controlled Jinja2 template code executes arbitrary Python directly on the host machine, bypassing all container isolation. Details The vulnerability exists in the generatecontainerfile() function at src/bentoml/internal/container/generate.py:155-157: This creates an unsandboxed jinja2.Environment with two dangerous extensions: - jinja2.ext.do — enables {% do %} tags that execute arbitrary Python expressions - jinja2.ext.debug — exposes internal template engine state Attack path: 1. Attacker builds a bento with dockerfiletemplate set in bentofile.yaml. During bentoml build, DockerOptions.writetobento() (buildconfig.py:272-276) copies the template file into the bento…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v959-cwq9-7hr6

  2. Revision 1 · created ·

    Published from osv record GHSA-v959-cwq9-7hr6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35044

Advisory: BentoML: SSTI via Unsandboxed Jinja2 in Dockerfile Generation
IDs: CVE-2026-35044, GHSA-v959-cwq9-7hr6
Record: https://patchnext.com/advisories/cve-2026-35044 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bentoml 1.4.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bentoml: affected <= 1.4.37; fixed in 1.4.38

## Suggested inspection (read-only)
- `python -m pip show bentoml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bentoml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v959-cwq9-7hr6 (OSV record GHSA-v959-cwq9-7hr6 lists affected ranges: PyPI bentoml >=0 <1.4.38 (fixed))
- Verified: https://github.com/advisories/GHSA-v959-cwq9-7hr6 (GitHub-reviewed advisory GHSA-v959-cwq9-7hr6 lists affected ranges: PyPI bentoml >=0 <=1.4.37)

Commands are suggestions: review each one before running it.

Loading voting…