Skip to content

← Actionable
High, CVSS 7.8amended

BentoML: Command Injection in cloud deployment setup script

CVE-2026-35043GHSA-fgv4-6jr3-jgfw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bentoml 1.4.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bentoml

    Affected
    <= 1.4.37
    Fixed in
    1.4.38

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-35043: 0.32% estimated exploitation activity in the next 30 days; percentile 25.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Commit ce53491 (March 24) fixed command injection via systempackages in Dockerfile templates and images.py by adding shlex.quote. However, the cloud deployment path in src/bentoml/internal/cloud/deployment.py was not included in the fix. Line 1648 interpolates systempackages directly into a shell command using an f-string without any quoting. The generated script is uploaded to BentoCloud as setup.sh and executed on the cloud build infrastructure during deployment, making this a remote code execution on the CI/CD tier. Details Fixed paths (commit ce53491): - src/bentomlsdk/images.py:88 - added shlex.quote(package) - src/bentoml/internal/bento/buildconfig.py:505 - added bashquote Jinja2 filter - Jinja2 templates: basedebian.j2, basealpine.j2, etc. Unfixed path: src/bentoml/internal/cloud/deployment.py, line 1648: def buildsetupscript(bentodir: str, image: Image | None) - bytes: content = b"" config = BentoBuildConfig.frombentodir(bentodir) if config.docker.systempackages: content +=…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fgv4-6jr3-jgfw

  2. Revision 1 · created ·

    Published from osv record GHSA-fgv4-6jr3-jgfw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35043

Advisory: BentoML: Command Injection in cloud deployment setup script
IDs: CVE-2026-35043, GHSA-fgv4-6jr3-jgfw
Record: https://patchnext.com/advisories/cve-2026-35043 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bentoml 1.4.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bentoml: affected <= 1.4.37; fixed in 1.4.38

## Suggested inspection (read-only)
- `python -m pip show bentoml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bentoml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fgv4-6jr3-jgfw (OSV record GHSA-fgv4-6jr3-jgfw lists affected ranges: PyPI bentoml >=0 <1.4.38 (fixed))
- Verified: https://github.com/advisories/GHSA-fgv4-6jr3-jgfw (GitHub-reviewed advisory GHSA-fgv4-6jr3-jgfw lists affected ranges: PyPI bentoml >=0 <=1.4.37)

Commands are suggestions: review each one before running it.

Loading voting…