Skip to content

← Actionable
Medium, CVSS 4.2amended

fast-jwt has a ReDoS when using RegExp in allowed* leading to CPU exhaustion during token verification

CVE-2026-35041GHSA-cjw9-ghj4-fwxf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 6.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-jwt

    Affected
    >= 5.0.0, <= 6.2.0
    Fixed in
    6.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-35041: 0.26% estimated exploitation activity in the next 30 days; percentile 18.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

⚠️ IMPORTANT CLARIFICATIONS

Affected Configurations This vulnerability ONLY affects applications that: - Use RegExp objects (not strings) in the allowedAud, allowedIss, allowedSub, allowedJti, or allowedNonce options - Configure patterns susceptible to catastrophic backtracking - Example: allowedAud: /^(a+)+X$/ ← VULNERABLE - Example: allowedAud: "api.company.com" ← SAFE

Not Affected - Applications using string patterns for audience validation (most common) - Applications using safe RegExp patterns without nested quantifiers - Default fast-jwt configurations

Assessment Guide To determine if you're affected: 1. Check ifallowedAud, allowedIss, allowedSub, allowedJti, or allowedNonce use RegExp objects (/pattern/ or new RegExp()) 2. If yes, review the pattern for nested quantifiers like (a+)+, (.), etc. 3. If no RegExp usage, you are NOT affected ------ <html <body <!--StartFragment--<h2 data-start="218" data-end="228"Summary</h2 <p data-start="230" data-end="364"A…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cjw9-ghj4-fwxf

  2. Revision 1 · created ·

    Published from osv record GHSA-cjw9-ghj4-fwxf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-35041

Advisory: fast-jwt has a ReDoS when using RegExp in allowed* leading to CPU exhaustion during token verification
IDs: CVE-2026-35041, GHSA-cjw9-ghj4-fwxf
Record: https://patchnext.com/advisories/cve-2026-35041 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-jwt 6.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-jwt: affected >= 5.0.0, <= 6.2.0; fixed in 6.2.1

## Suggested inspection (read-only)
- `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-jwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cjw9-ghj4-fwxf (OSV record GHSA-cjw9-ghj4-fwxf lists affected ranges: npm fast-jwt >=5.0.0 <6.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cjw9-ghj4-fwxf (GitHub-reviewed advisory GHSA-cjw9-ghj4-fwxf lists affected ranges: npm fast-jwt >=5.0.0 <=6.2.0)

Commands are suggestions: review each one before running it.

Loading voting…