fast-jwt: Cache Confusion via cacheKeyBuilder Collisions Can Return Claims From a Different Token (Identity/Authorization Mixup)
CVE-2026-35039GHSA-rp9m-7r4c-75qg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 6.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-jwt
- Affected
- >= 0.0.1, < 6.2.0
- Fixed in
- 6.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rp9m-7r4c-75qg lists affected ranges: npm fast-jwt >=0.0.1 <6.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rp9m-7r4c-75qg lists affected ranges: npm fast-jwt >=0.0.1 <6.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-35039: 0.22% estimated exploitation activity in the next 30 days; percentile 12.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NOTE: While the library exposes a mechanism which could introduce the vulnerability, this issue is created by developer-supplied code and not by the library itself. We will add a warning and some education for users around the possible issues however since the defaults work we will not be updating the library beyond that for this advisory. Impact Setting up a custom cacheKeyBuilder method which does not properly create unique keys for different tokens can lead to cache collisions. This could cause tokens to be mis-identified during the verification process leading to: - Valid tokens returning claims from different valid tokens - Users being mis-identified as other users based on the wrong token This could result in: - User impersonation - UserB receives UserA's identity and permissions - Privilege escalation - Low-privilege users inherit admin-level access - Cross-tenant data access - Users gain access to other tenants' resources - Authorization bypass - Security decisions made on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rp9m-7r4c-75qg
- Revision 2 · amended ·
Amended from osv record GHSA-rp9m-7r4c-75qg
- Revision 1 · created ·
Published from ghsa record GHSA-rp9m-7r4c-75qg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35039 Advisory: fast-jwt: Cache Confusion via cacheKeyBuilder Collisions Can Return Claims From a Different Token (Identity/Authorization Mixup) IDs: CVE-2026-35039, GHSA-rp9m-7r4c-75qg Record: https://patchnext.com/advisories/cve-2026-35039 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-jwt 6.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-jwt: affected >= 0.0.1, < 6.2.0; fixed in 6.2.0 ## Suggested inspection (read-only) - `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-jwt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rp9m-7r4c-75qg (GitHub-reviewed advisory GHSA-rp9m-7r4c-75qg lists affected ranges: npm fast-jwt >=0.0.1 <6.2.0) - Verified: https://osv.dev/vulnerability/GHSA-rp9m-7r4c-75qg (OSV record GHSA-rp9m-7r4c-75qg lists affected ranges: npm fast-jwt >=0.0.1 <6.2.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…