LiteLLM: Authentication bypass via OIDC userinfo cache key collision
CVE-2026-35030GHSA-jjhc-v7c2-5hh6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.83.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- < 1.83.0
- Fixed in
- 1.83.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jjhc-v7c2-5hh6 lists affected ranges: PyPI litellm >=0 <1.83.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jjhc-v7c2-5hh6 lists affected ranges: PyPI litellm >=0 <1.83.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2026-35030: 0.64% estimated exploitation activity in the next 30 days; percentile 50.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When JWT authentication is enabled (enablejwtauth: true), the OIDC userinfo cache uses token[:20] as the cache key. JWT headers produced by the same signing algorithm generate identical first 20 characters. This configuration option is not enabled by default. Most instances are not affected. An unauthenticated attacker can craft a token whose first 20 characters match a legitimate user's cached token. On cache hit, the attacker inherits the legitimate user's identity and permissions. This affects deployments with JWT/OIDC authentication enabled. Patches Fixed in v1.83.0. The cache key now uses the full hash of the JWT token. Workarounds Disable OIDC userinfo caching by setting the cache TTL to 0, or disable JWT authentication entirely.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-jjhc-v7c2-5hh6
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-jjhc-v7c2-5hh6
- Revision 1 · created ·
Published from ghsa record GHSA-jjhc-v7c2-5hh6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-35030 Advisory: LiteLLM: Authentication bypass via OIDC userinfo cache key collision IDs: CVE-2026-35030, GHSA-jjhc-v7c2-5hh6 Record: https://patchnext.com/advisories/cve-2026-35030 (revision 4, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litellm 1.83.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected < 1.83.0; fixed in 1.83.0 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jjhc-v7c2-5hh6 (GitHub-reviewed advisory GHSA-jjhc-v7c2-5hh6 lists affected ranges: PyPI litellm >=0 <1.83.0) - Verified: https://osv.dev/vulnerability/GHSA-jjhc-v7c2-5hh6 (OSV record GHSA-jjhc-v7c2-5hh6 lists affected ranges: PyPI litellm >=0 <1.83.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…