Skip to content

← Actionable
Critical, CVSS 9.1amended

PraisonAI Has Missing Authentication in WebSocket Gateway

CVE-2026-34952GHSA-cfh6-vr3j-qc3g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.97), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.5.96
    Fixed in
    4.5.97

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-34952: 0.45% estimated exploitation activity in the next 30 days; percentile 39.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The PraisonAI Gateway server accepts WebSocket connections at /ws and serves agent topology at /info with no authentication. Any network client can connect, enumerate registered agents, and send arbitrary messages to agents and their tool sets. Details gateway/server.py:242 (source) - gateway/server.py:250 (sink) PoC Impact Any unauthenticated attacker with network access can connect to the WebSocket gateway, enumerate all registered agents via /info, and send arbitrary messages to agents including tool execution, file reads, and API calls. GatewayConfig has an authtoken field that is never enforced in the handler. Suggested Fix

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cfh6-vr3j-qc3g

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cfh6-vr3j-qc3g

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cfh6-vr3j-qc3g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-34952

Advisory: PraisonAI Has Missing Authentication in WebSocket Gateway
IDs: CVE-2026-34952, GHSA-cfh6-vr3j-qc3g
Record: https://patchnext.com/advisories/cve-2026-34952 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.97. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.5.96; fixed in 4.5.97

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cfh6-vr3j-qc3g (GitHub-reviewed advisory GHSA-cfh6-vr3j-qc3g lists affected ranges: PyPI praisonai >=0 <=4.5.96)
- Verified: https://osv.dev/vulnerability/GHSA-cfh6-vr3j-qc3g (OSV record GHSA-cfh6-vr3j-qc3g lists affected ranges: PyPI praisonai >=0 <4.5.97 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…